summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCallum Mance2016-09-26 19:12:30 +0000
committerCallum Mance2016-09-26 19:12:30 +0000
commit40941809b2dc878b16835fd374dbc3903679aa61 (patch)
treec63837d09b2b9f9735cfd9952ee7f2f29842314a
downloadaur-40941809b2dc878b16835fd374dbc3903679aa61.tar.gz
Initial commit, add PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f968c992cba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cf-update-git
+ pkgdesc = Updater for Cloudflare DNS records
+ pkgver = v0.1.r2.g9f963c8
+ pkgrel = 1
+ url = https://github.com/callummance/CF-Update
+ arch = any
+ license = GPL3
+ depends = python
+ backup = etc/cf.conf
+ source = cf-update-git::git+https://github.com/callummance/CF-Update.git
+ md5sums = SKIP
+ sha1sums = SKIP
+ sha256sums = SKIP
+ sha512sums = SKIP
+
+pkgname = cf-update-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3a4ecb68803
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Callum Mance <callummance@gmail.com>
+pkgname=cf-update-git
+pkgver=v0.1.r2.g9f963c8
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+pkgrel=1
+epoch=
+pkgdesc="Updater for Cloudflare DNS records"
+arch=('any')
+url="https://github.com/callummance/CF-Update"
+license=('GPL3')
+groups=()
+depends=('python')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=('etc/cf.conf')
+options=()
+install=
+changelog=
+source=("$pkgname::git+https://github.com/callummance/CF-Update.git")
+noextract=()
+validpgpkeys=()
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/etc/cf-update"
+ install -m 755 -t "${pkgdir}/usr/bin/" ./cf-update
+ install -m 644 -t "${pkgdir}/etc/cf-update/" ./cf.conf
+}
+sha256sums=('SKIP')
+sha512sums=('SKIP')
+sha1sums=('SKIP')
+md5sums=('SKIP')