summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormapk0y2021-05-02 01:52:34 +0900
committermapk0y2021-05-02 01:52:34 +0900
commit5ab3efb73c7520594e413f6efcbcbe383b3f2e13 (patch)
tree43dc871d21f593c0cce9fb9ad5b441b503584043
downloadaur-5ab3efb73c7520594e413f6efcbcbe383b3f2e13.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f82b0f005419
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cfn-guard
+ pkgdesc = A set of tools to check AWS CloudFormation templates for policy compliance using a simple, policy-as-code, declarative syntax
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/aws-cloudformation/cloudformation-guard
+ arch = x86_64
+ license = Apache
+ depends = gcc-libs
+ provides = cfn-guard-git
+ source = cfn-guard-1.0.0.tar.gz::https://github.com/aws-cloudformation/cloudformation-guard/releases/download/1.0.0/cfn-guard-linux-1.0.0.tar.gz
+ sha256sums = e8b9e503257baaefdabb74311813b6d44eac64e05f10b9157569e5828d14370e
+
+pkgname = cfn-guard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acd822b30c7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Kazuya Yokogawa <mapk0y at gmail.com>
+
+pkgname='cfn-guard'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A set of tools to check AWS CloudFormation templates for policy compliance using a simple, policy-as-code, declarative syntax'
+url='https://github.com/aws-cloudformation/cloudformation-guard'
+license=('Apache')
+arch=('x86_64')
+depends=('gcc-libs')
+provides=("${pkgname}-git")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/${pkgname}-linux-${pkgver}.tar.gz")
+sha256sums=('e8b9e503257baaefdabb74311813b6d44eac64e05f10b9157569e5828d14370e')
+
+package() {
+ install -Dm755 ${srcdir}/cfn-guard-linux/cfn-guard "$pkgdir/usr/bin/cfn-guard"
+ install -Dm644 ${srcdir}/cfn-guard-linux/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 ${srcdir}/cfn-guard-linux/README.md "$pkgdir/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 ${srcdir}/cfn-guard-linux/ATTRIBUTION "$pkgdir/usr/share/doc/${pkgname}/ATTRIBUTION"
+ install -Dm644 ${srcdir}/cfn-guard-linux/NOTICE "$pkgdir/usr/share/doc/${pkgname}/NOTICE"
+}