summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormapk0y2023-09-09 04:45:36 +0900
committermapk0y2023-09-09 04:45:36 +0900
commiteeb05ed1b7c3be4fe8915b378918ab6461be6b34 (patch)
treeea50bcb1a88d0ba899ed137bb4c5e7438a4ced25
parent345c7b385422aa1ffd479946850afd92479a92b4 (diff)
downloadaur-eeb05ed1b7c3be4fe8915b378918ab6461be6b34.tar.gz
Update to v3.0.1
- Update version
-rw-r--r--.SRCINFO8
-rw-r--r--Makefile3
-rw-r--r--PKGBUILD6
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ceeaa3abb75..1cde762d0556 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = cfn-guard
pkgdesc = Guard offers a policy-as-code domain-specific language (DSL) to write rules and validate JSON- and YAML-formatted data such as CloudFormation Templates, K8s configurations, and Terraform JSON plans/configurations against those rules.
- pkgver = 3.0.0
- pkgrel = 2
+ pkgver = 3.0.1
+ pkgrel = 1
url = https://github.com/aws-cloudformation/cloudformation-guard
arch = x86_64
license = Apache
depends = gcc-libs
conflicts = cfn-guard-git
- source = https://github.com/aws-cloudformation/cloudformation-guard/releases/download/3.0.0/cfn-guard-v3-ubuntu-latest.tar.gz
- sha256sums = 6aa93074ce470782c388ffbcf391981ea3c2f806c41e4dce1a63c9415f7e9c2b
+ source = https://github.com/aws-cloudformation/cloudformation-guard/releases/download/3.0.1/cfn-guard-v3-ubuntu-latest.tar.gz
+ sha256sums = 7fbdb4fd7cf3f0ef2498717da3b8b4308d7ab405cdfd5a05213dd1a1e0e7b6a7
pkgname = cfn-guard
diff --git a/Makefile b/Makefile
index cbc2f5ad4e58..2ef4b9cea761 100644
--- a/Makefile
+++ b/Makefile
@@ -37,11 +37,12 @@ package_auto: update_tag ## Auto packaging
clean: ## remove tar.gz
rm -vf *.tar.xz *.tar.gz
-update_tag: LATEST := "$(shell curl -sL https://api.github.com/repos/aws-cloudformation/cloudformation-guard/releases/latest | jq -r '.tag_name|ltrimstr("v")')"
+update_tag: LATEST := $(shell curl -sL https://api.github.com/repos/aws-cloudformation/cloudformation-guard/releases/latest | jq -r '.tag_name|ltrimstr("v")')
update_tag: ## get and update newest version in PKGBUILD
source ./PKGBUILD && \
if [[ $${pkgver} != $(LATEST) ]]; then \
sed -i -e 's/^pkgver=.*$$/pkgver=$(LATEST)/' ./PKGBUILD && \
+ sed -i -e 's/^pkgrel=.*$$/pkgrel=1/' ./PKGBUILD && \
updpkgsums && \
git diff ./PKGBUILD; \
fi
diff --git a/PKGBUILD b/PKGBUILD
index 32a791e2cc01..b2dd99856745 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Kazuya Yokogawa <mapk0y at gmail.com>
pkgname='cfn-guard'
-pkgver=3.0.0
-pkgrel=2
+pkgver=3.0.1
+pkgrel=1
pkgdesc='Guard offers a policy-as-code domain-specific language (DSL) to write rules and validate JSON- and YAML-formatted data such as CloudFormation Templates, K8s configurations, and Terraform JSON plans/configurations against those rules.'
url='https://github.com/aws-cloudformation/cloudformation-guard'
license=('Apache')
@@ -10,7 +10,7 @@ arch=('x86_64')
depends=('gcc-libs')
conflicts=("cfn-guard-git")
source=("${url}/releases/download/${pkgver}/${pkgname}-v3-ubuntu-latest.tar.gz")
-sha256sums=('6aa93074ce470782c388ffbcf391981ea3c2f806c41e4dce1a63c9415f7e9c2b')
+sha256sums=('7fbdb4fd7cf3f0ef2498717da3b8b4308d7ab405cdfd5a05213dd1a1e0e7b6a7')
build() {
${srcdir}/cfn-guard-v3-ubuntu-latest/cfn-guard completions --shell='zsh' > cfn-guard.zsh