summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormapk0y2021-05-18 12:47:20 +0900
committermapk0y2021-05-18 12:47:20 +0900
commit45544c011df7b65db8445081dafc58b7754c5084 (patch)
tree9077a00594a550628d4cd6796c84bc7d8605c679
parent76dc687b029cef5a29148079426156761f84be8e (diff)
downloadaur-45544c011df7b65db8445081dafc58b7754c5084.tar.gz
Update to 2.0.1 (makepkg -s && mksrcinfo)
- with `namcap -i` check
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3684a482571f..af5e24ff731d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = cfn-guard-git
pkgdesc = A set of tools to check AWS CloudFormation templates for policy compliance using a simple, policy-as-code, declarative syntax
- pkgver = 1.0.0.r40.g245d7b1
+ pkgver = 2.0.1.r0.gf560098
pkgrel = 1
url = https://github.com/aws-cloudformation/cloudformation-guard
arch = x86_64
license = Apache
makedepends = rust
depends = gcc-libs
+ conflicts = cfn-guard
source = git+https://github.com/aws-cloudformation/cloudformation-guard
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f577e35223b9..4637217d6a7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kazuya Yokogawa <mapk0y at gmail.com>
pkgname='cfn-guard-git'
-pkgver=1.0.0.r40.g245d7b1
+pkgver=2.0.1.r0.gf560098
pkgrel=1
pkgdesc='A set of tools to check AWS CloudFormation templates for policy compliance using a simple, policy-as-code, declarative syntax'
url='https://github.com/aws-cloudformation/cloudformation-guard'
@@ -9,6 +9,7 @@ depends=('gcc-libs')
makedepends=('rust')
license=('Apache')
arch=('x86_64')
+conflicts=("cfn-guard")
source=('git+https://github.com/aws-cloudformation/cloudformation-guard')
md5sums=('SKIP')
@@ -19,12 +20,12 @@ pkgver() {
build() {
cd "$srcdir"/cloudformation-guard
- make cfn-guard
+ cargo build --release
}
package() {
cd "$srcdir"/cloudformation-guard
- install -Dm755 bin/cfn-guard "$pkgdir/usr/bin/cfn-guard"
+ install -Dm755 target/release/cfn-guard "$pkgdir/usr/bin/cfn-guard"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 README.md "$pkgdir/usr/share/doc/${pkgname%-*}/README.md"
}