summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Edgecombe2013-12-12 13:16:59 +0000
committerGraham Edgecombe2013-12-12 13:16:59 +0000
commitdd3af6e927daa9ea933e1a2653ac7122ed27bfdd (patch)
tree01b1d35ae565e8c2159b5b7ab46f5016c5b69aa1
downloadaur-dd3af6e927daa9ea933e1a2653ac7122ed27bfdd.tar.gz
Add initial cfr package.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD21
-rwxr-xr-xcfr2
5 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff5dc255ac07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cfr
+ pkgdesc = Another Java decompiler
+ pkgver = 0_57
+ pkgrel = 1
+ url = http://www.benf.org/other/cfr/
+ arch = any
+ license = MIT
+ depends = java-runtime
+ noextract = cfr_0_57.jar
+ source = http://www.benf.org/other/cfr/cfr_0_57.jar
+ source = cfr
+ source = LICENSE
+ md5sums = b71924966563cc5b98569f6dcff07153
+ md5sums = d0f7cff1f51f2b25139e4855bf0520ee
+ md5sums = 94f3aea3b6c6ef49be7d3d27be0d5f84
+
+pkgname = cfr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ba9e06b09cc7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/cfr_*.jar
+/src
+/pkg
+*.pkg.tar.xz
+*.pkg.tar.xz.sig
+*.src.tar.gz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0791a0d4075d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+Sourced from The MIT License (MIT)
+
+Copyright (c) 2011-2013 Lee Benfield - http://www.benf.org/other/cfr
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c178da617954
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Graham Edgecombe <graham@grahamedgecombe.com>
+pkgname=cfr
+pkgver=0_57
+pkgrel=1
+pkgdesc='Another Java decompiler'
+arch=('any')
+url='http://www.benf.org/other/cfr/'
+license=('MIT')
+depends=('java-runtime')
+source=("http://www.benf.org/other/cfr/cfr_${pkgver}.jar"
+ 'cfr' 'LICENSE')
+noextract=("cfr_${pkgver}.jar")
+md5sums=('b71924966563cc5b98569f6dcff07153'
+ 'd0f7cff1f51f2b25139e4855bf0520ee'
+ '94f3aea3b6c6ef49be7d3d27be0d5f84')
+
+package() {
+ install -D cfr "$pkgdir/usr/bin/cfr"
+ install -Dm644 "cfr_${pkgver}.jar" "$pkgdir/usr/share/java/cfr/cfr.jar"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/cfr/LICENSE"
+}
diff --git a/cfr b/cfr
new file mode 100755
index 000000000000..21e890d5fd6f
--- /dev/null
+++ b/cfr
@@ -0,0 +1,2 @@
+#!/bin/sh -e
+exec "$JAVA_HOME/bin/java" -jar /usr/share/java/cfr/cfr.jar "$@"