summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Gribov2018-04-09 21:31:38 +0300
committerKonstantin Gribov2018-04-09 21:31:38 +0300
commit667aad65b6373718f89d98f8a8a35a4b6ae4eab2 (patch)
treee954bf07646277ece096f19e27572ad00bceec50
parent6e6824614156a2b986850853533b9768428cc34c (diff)
downloadaur-667aad65b6373718f89d98f8a8a35a4b6ae4eab2.tar.gz
Added GOPATH export in build()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba9db2c4eda1..21c5e091c569 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cfssl
pkgdesc = CloudFlare PKI and TLS toolkit
pkgver = 1.3.2
- pkgrel = 2
+ pkgrel = 3
url = https://cfssl.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c2ca537cc1f5..df36675c2fd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cfssl
pkgver=1.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="CloudFlare PKI and TLS toolkit"
arch=('i686' 'x86_64')
url="https://cfssl.org/"
@@ -20,12 +20,15 @@ _binaries=(cfssl cfssljson cfssl-bundle cfssl-certinfo cfssl-newkey cfssl-scan m
prepare () {
export GOPATH="${srcdir}"
export PATH="$GOPATH/bin:$PATH"
+
mkdir -p src/github.com/cloudflare/
rm -rf src/${_prefix}
mv "${pkgname}-${pkgver}" src/${_prefix}
}
build() {
+ export GOPATH="${srcdir}"
+
for bin in ${_binaries[@]} ; do
echo "building $bin"
go install ${_prefix}/cmd/${bin}