summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Gribov2015-12-22 02:16:49 +0300
committerKonstantin Gribov2015-12-22 02:16:49 +0300
commit9b5789d097c51d66f63ac13ccfe0062c568295aa (patch)
treeeb660c796b9bfbb16baf623b608c9ca5b594ef69
downloadaur-9b5789d097c51d66f63ac13ccfe0062c568295aa.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore17
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD31
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dec5430e59e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 23:15:06 UTC 2015
+pkgbase = cfssl
+ pkgdesc = CloudFlare PKI and TLS toolkit
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://cfssl.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = gcc-go
+ makedepends = libtool
+ depends = glibc
+ source = LICENSE::https://raw.githubusercontent.com/cloudflare/cfssl/1.1.0/LICENSE
+ sha256sums = dc439285c60b63ec585769cf151a03345654a78271cdfd56250f59f1175fba88
+ source_i686 = cfssl::https://pkg.cfssl.org/R1.1/cfssl_linux-386
+ source_i686 = cfssljson::https://pkg.cfssl.org/R1.1/cfssljson_linux-386
+ source_i686 = cfssl_mkbundle::https://pkg.cfssl.org/R1.1/mkbundle_linux-386
+ sha256sums_i686 = 6538c2618ab9600a925ef60c5a19841e1e96e72ad013cc54c03f4ccca7ebbec0
+ sha256sums_i686 = 0cbeb9031e5b2ebf0184af2b1a4ec44162171c77374107117f785cb685f7ce96
+ sha256sums_i686 = 3c7a81753edfe272cf97a5a9adc2319a573225d3acfe7b13365e6f9a15f9dfb9
+ source_x86_64 = cfssl::https://pkg.cfssl.org/R1.1/cfssl_linux-amd64
+ source_x86_64 = cfssljson::https://pkg.cfssl.org/R1.1/cfssljson_linux-amd64
+ source_x86_64 = cfssl_mkbundle::https://pkg.cfssl.org/R1.1/mkbundle_linux-amd64
+ sha256sums_x86_64 = 92ef224956608685d22bd607d0bbd2cd957c2ea1adf42fdf1e977a3d1f3ff91c
+ sha256sums_x86_64 = a2b86daff6b52921d5149d6d4e1c12bfd609330e309aa80aeea8ee60af332257
+ sha256sums_x86_64 = df339a7a4be205f558c969db24ba0b37335cd9d2516974d2a2cb6933732afcc8
+
+pkgname = cfssl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..001569c0d6ca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+# build dirs
+/src/
+/pkg/
+
+# archives
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.zip
+
+# tmp
+.*.swp
+*~
+
+# binaries
+/cfssl*
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..bc5841fa5597
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+Copyright (c) 2014 CloudFlare Inc.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+Redistributions of source code must retain the above copyright notice,
+this list of conditions and the following disclaimer.
+
+Redistributions in binary form must reproduce the above copyright notice,
+this list of conditions and the following disclaimer in the documentation
+and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05c82252b968
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Konstantin Gribov <grossws@gmail.com>
+
+pkgname=cfssl
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="CloudFlare PKI and TLS toolkit"
+arch=('i686' 'x86_64')
+url="https://cfssl.org/"
+license=('BSD')
+depends=('glibc')
+makedepends=('gcc-go' 'libtool')
+
+source_x86_64=("cfssl::https://pkg.cfssl.org/R1.1/cfssl_linux-amd64"
+ "cfssljson::https://pkg.cfssl.org/R1.1/cfssljson_linux-amd64"
+ "cfssl_mkbundle::https://pkg.cfssl.org/R1.1/mkbundle_linux-amd64")
+source_i686=("cfssl::https://pkg.cfssl.org/R1.1/cfssl_linux-386"
+ "cfssljson::https://pkg.cfssl.org/R1.1/cfssljson_linux-386"
+ "cfssl_mkbundle::https://pkg.cfssl.org/R1.1/mkbundle_linux-386")
+source=("LICENSE::https://raw.githubusercontent.com/cloudflare/${pkgname}/${pkgver}/LICENSE")
+sha256sums_x86_64=('92ef224956608685d22bd607d0bbd2cd957c2ea1adf42fdf1e977a3d1f3ff91c'
+ 'a2b86daff6b52921d5149d6d4e1c12bfd609330e309aa80aeea8ee60af332257'
+ 'df339a7a4be205f558c969db24ba0b37335cd9d2516974d2a2cb6933732afcc8')
+sha256sums_i686=('6538c2618ab9600a925ef60c5a19841e1e96e72ad013cc54c03f4ccca7ebbec0'
+ '0cbeb9031e5b2ebf0184af2b1a4ec44162171c77374107117f785cb685f7ce96'
+ '3c7a81753edfe272cf97a5a9adc2319a573225d3acfe7b13365e6f9a15f9dfb9')
+sha256sums=('dc439285c60b63ec585769cf151a03345654a78271cdfd56250f59f1175fba88')
+
+package() {
+ install -m755 -D -t "${pkgdir}/usr/bin/" cfssl cfssljson cfssl_mkbundle
+ install -m644 -D LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}