summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-01-09 15:35:29 +0100
committerMichel Zou2022-01-09 15:35:29 +0100
commit7d96a6f83b881bcff4353677e79a9b42fa1527ec (patch)
tree5c9c16ac6b104cb8695981122ae18c2dae585b3a
parentfadf013c5a287aa2c241d1dc80b2c80b07f9e0d3 (diff)
downloadaur-7d96a6f83b881bcff4353677e79a9b42fa1527ec.tar.gz
cgal5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eaf30e177cdd..1f2bbb2ce164 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = cgal-swig-bindings
pkgdesc = CGAL bindings using SWIG
- pkgver = r621.a04a496
+ pkgver = r765.2479e35
pkgrel = 1
url = https://github.com/CGAL/cgal-swig-bindings
arch = i686
arch = x86_64
license = custom: Boost
- makedepends = cgal
+ makedepends = cgal-headers
makedepends = cmake
- makedepends = swig3
+ makedepends = swig
makedepends = eigen
makedepends = python
makedepends = java-runtime
makedepends = git
+ depends = tbb
+ depends = boost
source = git+https://github.com/CGAL/cgal-swig-bindings.git
md5sums = SKIP
@@ -23,4 +25,3 @@ pkgname = python-cgal
pkgname = java-cgal
depends = java-runtime
depends = cgal
-
diff --git a/PKGBUILD b/PKGBUILD
index 4c4714c873e3..e19c8e6c80a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
pkgbase=cgal-swig-bindings
pkgname=('python-cgal' 'java-cgal')
-pkgver=r621.a04a496
+pkgver=r765.2479e35
pkgrel=1
pkgdesc='CGAL bindings using SWIG '
arch=('i686' 'x86_64')
license=('custom: Boost')
url="https://github.com/CGAL/cgal-swig-bindings"
-makedepends=('cgal' 'cmake' 'swig3' 'eigen' 'python' 'java-runtime' 'git')
+makedepends=('cgal-headers' 'cmake' 'swig' 'eigen' 'python' 'java-runtime' 'git')
+depends=('tbb' 'boost')
source=("git+https://github.com/CGAL/cgal-swig-bindings.git")
md5sums=('SKIP')
@@ -20,7 +21,7 @@ build()
cd "$srcdir"/cgal-swig-bindings
mkdir -p build && pushd build
cmake \
- -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DSWIG_EXECUTABLE=/usr/bin/swig-3 ..
+ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
make
ctest -j2 -R python -E polyline_simplification_2 --output-on-failure
}