summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2015-09-09 04:38:39 +0200
committerDario Ostuni2015-09-09 04:38:39 +0200
commit9dd9e917076c569d3621b88320cb53f1733455de (patch)
treea96ce653629415c75124e96d9185143fd4261805
downloadaur-9dd9e917076c569d3621b88320cb53f1733455de.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..472a3e40c39a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cgicc
+ pkgdesc = C++ library that simplifies the creation of CGI applications
+ pkgver = 3.2.16
+ pkgrel = 1
+ url = https://www.gnu.org/software/cgicc/
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = doxygen
+ source = http://ftp.gnu.org/gnu/cgicc/cgicc-3.2.16.tar.gz
+ sha256sums = 9dceb36d2da52791ee11f2fb5bb6435c22e69ef50f38073c4329386b883d5aaa
+
+pkgname = cgicc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eaac66ef9b81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Dario Ostuni <another.code.996@gmail.com>
+pkgname=cgicc
+pkgver=3.2.16
+pkgrel=1
+pkgdesc="C++ library that simplifies the creation of CGI applications"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/cgicc/"
+license=('LGPL3')
+makedepends=('doxygen')
+source=("http://ftp.gnu.org/gnu/cgicc/$pkgname-$pkgver.tar.gz")
+sha256sums=('9dceb36d2da52791ee11f2fb5bb6435c22e69ef50f38073c4329386b883d5aaa')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}