summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2015-07-12 19:15:43 +0200
committereolianoe2015-07-12 19:15:43 +0200
commit70905c80f62c36483c65336a8ea4ebe0607e345c (patch)
tree23bf8400bf22626ba72f6289f20abc3469177285
downloadaur-70905c80f62c36483c65336a8ea4ebe0607e345c.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD73
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca2bcf089349
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cgns
+ pkgdesc = Standard for recording and recovering computer data associated with the numerical solution of fluid dynamics equations
+ pkgver = 3.2.1
+ pkgrel = 1
+ url = http://www.cgns.org
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gcc-fortran
+ makedepends = cmake
+ depends = tk
+ depends = hdf5
+ depends = libxmu
+ depends = glu
+ provides = libcgns
+ provides = libcgns-paraview
+ conflicts = ligcgns2
+ source = cgns-3.2.1.tar.gz::https://github.com/CGNS/CGNS/archive/v3.2.1.tar.gz
+ sha256sums = 677d0da94f0892b72b96da7cf4de51f661acfff1141c585af50a531fa161773f
+
+pkgname = cgns
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6d3d3c73f0cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.gz
+*.xz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8801b8b07f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: eolianoe <eolianoe At GoogleMAIL DoT com>
+# Contriburor: Mathias Anselmann <mathias.anselmann@gmail.com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: lainme <lainme993@gmail.com>
+# Contributor: Klimov Max <cleemmi@gmail.com>
+
+pkgname=cgns
+_PKGNAME=CGNS
+pkgver=3.2.1
+pkgrel=1
+pkgdesc='Standard for recording and recovering computer data associated with the numerical solution of fluid dynamics equations'
+arch=('i686' 'x86_64')
+url='http://www.cgns.org'
+license=('custom')
+provides=('libcgns' 'libcgns-paraview')
+conflicts=('ligcgns2')
+depends=('tk' 'hdf5' 'libxmu' 'glu')
+makedepends=('gcc-fortran' 'cmake')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/${_PKGNAME}/${_PKGNAME}/archive/v${pkgver}.tar.gz")
+sha256sums=('677d0da94f0892b72b96da7cf4de51f661acfff1141c585af50a531fa161773f')
+
+# need to tell cmake when to build 64bit version
+if [[ $CARCH == "x86_64" ]]
+then
+ _64bits=ON
+else
+ _64bits=OFF
+fi
+
+prepare(){
+ cd "${srcdir}"
+
+ # Out of source build
+ rm -rf build
+ mkdir -p build
+}
+
+build() {
+ cd "${srcdir}/build"
+
+ cmake \
+ -DCGNS_BUILD_CGNSTOOLS:BOOL=ON \
+ -DCGNS_BUILD_SHARED:BOOL=ON \
+ -DCGNS_ENABLE_64BIT:BOOL=${_64bits} \
+ -DCGNS_ENABLE_FORTRAN:BOOL=ON \
+ -DCGNS_ENABLE_HDF5:BOOL=ON \
+ -DCGNS_ENABLE_LEGACY:BOOL=ON \
+ -DCGNS_ENABLE_SCOPING:BOOL=OFF \
+ -DCGNS_ENABLE_TESTS:BOOL=ON \
+ -DCMAKE_BUILD_TYPE:STRING="Release" \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_SKIP_RPATH:BOOL=ON \
+ "../${_PKGNAME}-${pkgver}"
+
+ make
+}
+
+
+check() {
+ cd "${srcdir}/build"
+
+ make test
+}
+
+package() {
+ cd "${srcdir}/build"
+
+ make DESTDIR="${pkgdir}" install
+
+ # install license
+ install -Dm644 "${srcdir}/${_PKGNAME}-${pkgver}/license.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+}