summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrZingo2019-08-09 01:48:59 +0200
committerDrZingo2019-08-09 01:48:59 +0200
commit447e4886d76b55395455e3ebc5841c86a6db65c4 (patch)
tree19f714aab0bb3ede3138b80de5ecb64d24089170
downloadaur-447e4886d76b55395455e3ebc5841c86a6db65c4.tar.gz
First commit
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD47
-rw-r--r--cgchat.1.gzbin0 -> 1273 bytes
-rw-r--r--cgterm.1.gzbin0 -> 1994 bytes
5 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f29a32dd203f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cgterm-git
+ pkgdesc = C/G telnet client that lets you connect to C64 telnet BBS
+ pkgver = r1.01e35d6
+ pkgrel = 1
+ url = https://github.com/MagerValp/CGTerm
+ arch = i686
+ arch = x86_64
+ license = custom:BSD
+ makedepends = git
+ depends = sdl
+ source = cgterm-git::git+https://github.com/MagerValp/CGTerm.git
+ source = cgterm.1.gz
+ source = cgchat.1.gz
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = b3913ae8dfa64f5dfd2fc830c7e62a83
+ md5sums = 1fa28dc46a84150a4a52184aec1e3146
+ md5sums = 01f185b2b35869909ccef6332ac369ef
+
+pkgname = cgterm-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..29d70556cb07
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,28 @@
+CGTerm is released under a slightly modified BSD license:
+
+Copyright (c) 2003, Per Olofsson
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials provided
+ with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88fdf8aedb71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: DrZingo <markus at borgelin dot org>
+# This package contains man-pages created from txt-files in the source.
+
+pkgname=cgterm-git
+_gitname=CGTerm
+pkgver=r1.01e35d6
+pkgrel=1
+pkgdesc="C/G telnet client that lets you connect to C64 telnet BBS"
+arch=('i686' 'x86_64')
+url="https://github.com/MagerValp/CGTerm"
+license=('custom:BSD')
+depends=('sdl')
+makedepends=('git')
+source=( "$pkgname"::'git+https://github.com/MagerValp/CGTerm.git' 'cgterm.1.gz' 'cgchat.1.gz' 'LICENSE' )
+md5sums=(
+ 'SKIP'
+ 'b3913ae8dfa64f5dfd2fc830c7e62a83'
+ '1fa28dc46a84150a4a52184aec1e3146'
+ '01f185b2b35869909ccef6332ac369ef'
+)
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${pkgname}"
+ sed -i -e 's/^PREFIX=.*$/PREFIX=\/usr/g' -e 's/-O3 -Wall /-O3 /g' -e 's/mkdir \$(PREFIX)/mkdir -p \$(PREFIX)/g' Makefile
+}
+
+build() {
+ cd "${pkgname}"
+ make all
+}
+
+package() {
+ cd "${pkgname}"
+ make PREFIX="${pkgdir}/usr" install || return 1
+ rmdir $pkgdir/usr/etc || return 1
+
+ install -Dm644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE || return 1
+ install -Dm644 $srcdir/cgterm.1.gz $pkgdir/usr/share/man/man1/cgterm.1.gz || return 1
+ install -Dm644 $srcdir/cgchat.1.gz $pkgdir/usr/share/man/man1/cgchat.1.gz || return 1
+}
+
+# vim:set ts=4 sw=4 et:
diff --git a/cgchat.1.gz b/cgchat.1.gz
new file mode 100644
index 000000000000..b8eafdfee969
--- /dev/null
+++ b/cgchat.1.gz
Binary files differ
diff --git a/cgterm.1.gz b/cgterm.1.gz
new file mode 100644
index 000000000000..f6dd2eca6ab8
--- /dev/null
+++ b/cgterm.1.gz
Binary files differ