summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2018-05-04 21:08:49 +0200
committerSebastian 'Swift Geek' Grzywna2018-05-04 21:08:49 +0200
commit78b561c7a0af8c3873f575df25474a7e25140910 (patch)
treefb597d576c6b3269201b7cf7f8d073b30c6a3fd5
downloadaur-78b561c7a0af8c3873f575df25474a7e25140910.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d4ffe2ddda9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri May 4 19:08:35 UTC 2018
+pkgbase = ch341eeprom-git
+ pkgdesc = A libusb based programming tool for 24xx I²C EEPROMs using the WCH CH341A
+ pkgver = r33.cc398a0
+ pkgrel = 1
+ url = https://github.com/commandtab/ch341eeprom
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ makedepends = git
+ depends = libusb>=1
+ source = ch341eeprom::git+https://github.com/commandtab/ch341eeprom.git
+ md5sums = SKIP
+
+pkgname = ch341eeprom-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3884a2431db2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=ch341eeprom-git
+_gitname=ch341eeprom
+pkgver=r33.cc398a0
+pkgrel=1
+pkgdesc="A libusb based programming tool for 24xx I²C EEPROMs using the WCH CH341A"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/commandtab/ch341eeprom"
+license=('GPL')
+depends=('libusb>=1')
+makedepends=('git')
+source=("${_gitname}::git+https://github.com/commandtab/ch341eeprom.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+
+ # Get the version number
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+
+ # Install the program
+ install -Dm755 ch341eeprom "${pkgdir}/usr/bin/ch341eeprom"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
+}
+
+# vim:set ft=sh ts=2 sw=2 et: