summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-15 18:41:24 +0800
committerzxp198210052024-01-15 18:41:24 +0800
commit0efe35434e5ad0e08c132432c56b7243669ea1c3 (patch)
tree1e79a2c6d038fe71a290a1648e1ace006e6bb858
parentb1452983f1acc48f3a818376fbb9fac70082471b (diff)
downloadaur-0efe35434e5ad0e08c132432c56b7243669ea1c3.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--chain-desktop-wallet.sh13
3 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc645b249221..841b697c7e34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
pkgbase = chain-desktop-wallet-bin
pkgdesc = Crypto.com DeFi Desktop Wallet
pkgver = 1.4.6
- pkgrel = 1
+ pkgrel = 2
url = https://crypto.com/defi-wallet
arch = x86_64
license = Apache
makedepends = squashfuse
depends = electron19
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
provides = chain-desktop-wallet=1.4.6
conflicts = chain-desktop-wallet
source = chain-desktop-wallet-1.4.6.AppImage::https://github.com/crypto-com/chain-desktop-wallet/releases/download/v1.4.6/Crypto.com-DeFi-Desktop-Wallet-1.4.6.AppImage
source = chain-desktop-wallet.sh
sha256sums = 4e02ffb9e4322438b414b6040455b1a43a674a910437abdc274806f0d2d47e82
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = chain-desktop-wallet-bin
diff --git a/PKGBUILD b/PKGBUILD
index 16f4642ac1bc..0e7600fb30e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chain-desktop-wallet-bin
pkgver=1.4.6
_electronversion=19
-pkgrel=1
+pkgrel=2
pkgdesc="Crypto.com DeFi Desktop Wallet"
arch=('x86_64')
url="https://crypto.com/defi-wallet"
@@ -12,12 +12,9 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
)
makedepends=(
'squashfuse'
@@ -27,7 +24,7 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('4e02ffb9e4322438b414b6040455b1a43a674a910437abdc274806f0d2d47e82'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -35,7 +32,7 @@ build() {
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
}
package() {
diff --git a/chain-desktop-wallet.sh b/chain-desktop-wallet.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/chain-desktop-wallet.sh
+++ b/chain-desktop-wallet.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file