summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-25 18:44:04 +0800
committerzxp198210052023-10-25 18:44:04 +0800
commit2718e3ad07fcf9a36c92ec4ed7bbeaceddd30f2e (patch)
tree18601bd57bcfa24e540a4469b121291bc1c20f7c
parentfca0c055f21f89cbecc3b9b18d99922f6e44d77a (diff)
downloadaur-2718e3ad07fcf9a36c92ec4ed7bbeaceddd30f2e.tar.gz
update to 1.4.5
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--chain-desktop-wallet.sh5
3 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02143432454e..d3bb02b4b499 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = chain-desktop-wallet-bin
pkgdesc = Crypto.com DeFi Desktop Wallet
- pkgver = 1.4.3
+ pkgver = 1.4.5
pkgrel = 1
url = https://crypto.com/defi-wallet
arch = x86_64
license = Apache
+ makedepends = squashfuse
depends = bash
depends = electron19
- depends = glibc
- provides = chain-desktop-wallet=1.4.3
+ provides = chain-desktop-wallet=1.4.5
conflicts = chain-desktop-wallet
- source = chain-desktop-wallet-1.4.3.AppImage::https://github.com/crypto-com/chain-desktop-wallet/releases/download/v1.4.3/Crypto.com-DeFi-Desktop-Wallet-1.4.3.AppImage
+ source = chain-desktop-wallet-1.4.5.AppImage::https://github.com/crypto-com/chain-desktop-wallet/releases/download/v1.4.5/Crypto.com-DeFi-Desktop-Wallet-1.4.5.AppImage
source = chain-desktop-wallet.sh
- sha256sums = 4d51557c41558713b9424088a5411dba9bebdbaa3bd4038300a62809385638fe
- sha256sums = 2f97c9c18cc0629d1afe4c6cb94e0d03dfb29e31a7ead8fc7e1a10b55201e328
+ sha256sums = e3dffdf9f12cbb2cf800a80c3f2e520d842a1525d43844cc544cd2599b773e68
+ sha256sums = 091d1f9251158c9d6503cae3a5c60f21697957a9c5bbacc0c9dfa1e037f2bbf4
pkgname = chain-desktop-wallet-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8a36a368f06d..d1085770869f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=chain-desktop-wallet-bin
-pkgver=1.4.3
+pkgver=1.4.5
pkgrel=1
pkgdesc="Crypto.com DeFi Desktop Wallet"
arch=('x86_64')
@@ -9,21 +9,24 @@ _githuburl="https://github.com/crypto-com/chain-desktop-wallet"
license=("Apache")
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron19' 'glibc')
+depends=('bash' 'electron19')
+makedepends=('squashfuse')
source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/Crypto.com-DeFi-Desktop-Wallet-${pkgver}.AppImage"
"${pkgname%-bin}.sh")
-sha256sums=('4d51557c41558713b9424088a5411dba9bebdbaa3bd4038300a62809385638fe'
- '2f97c9c18cc0629d1afe4c6cb94e0d03dfb29e31a7ead8fc7e1a10b55201e328')
-prepare() {
+sha256sums=('e3dffdf9f12cbb2cf800a80c3f2e520d842a1525d43844cc544cd2599b773e68'
+ '091d1f9251158c9d6503cae3a5c60f21697957a9c5bbacc0c9dfa1e037f2bbf4')
+build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
- cp -r "${srcdir}/squashfs-root/resources/"{app.asar.unpacked,scripts} "${pkgdir}/opt/${pkgname%-bin}/resources"
+ install -Dm644 "${srcdir}/squashfs-root/resources/scripts/preload.js" -t "${pkgdir}/opt/${pkgname%-bin}/resources/scripts"
+ cp -r "${srcdir}/squashfs-root/resources/app.asar.unpacked" "${pkgdir}/opt/${pkgname%-bin}/resources"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/opt/${pkgname%-bin}/usr/lib"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file
diff --git a/chain-desktop-wallet.sh b/chain-desktop-wallet.sh
index 47a3cd4fb9f3..27ef0691d416 100644
--- a/chain-desktop-wallet.sh
+++ b/chain-desktop-wallet.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron19
-_ASAR="/opt/chain-desktop-wallet/resources/app.asar"
+APPDIR="/opt/chain-desktop-wallet"
+export PATH="${APPDIR}:${APPDIR}/usr/sbin:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/usr/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/resources/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else