summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-18 13:54:56 +0800
committerzxp198210052023-09-18 13:54:56 +0800
commitfca0c055f21f89cbecc3b9b18d99922f6e44d77a (patch)
tree1d40bbb58e7aacbbb8417d041291b60143aadb3a
parent365513ad42dfa2d48ebad600a9e464a22abbe726 (diff)
downloadaur-fca0c055f21f89cbecc3b9b18d99922f6e44d77a.tar.gz
update to 1.4.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--chain-desktop-wallet.sh2
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94c3f4877e7d..02143432454e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = chain-desktop-wallet-bin
pkgdesc = Crypto.com DeFi Desktop Wallet
- pkgver = 1.4.2
- pkgrel = 3
+ pkgver = 1.4.3
+ pkgrel = 1
url = https://crypto.com/defi-wallet
arch = x86_64
license = Apache
depends = bash
depends = electron19
depends = glibc
- provides = chain-desktop-wallet=1.4.2
+ provides = chain-desktop-wallet=1.4.3
conflicts = chain-desktop-wallet
- source = chain-desktop-wallet-1.4.2.AppImage::https://github.com/crypto-com/chain-desktop-wallet/releases/download/v1.4.2/Crypto.com-DeFi-Desktop-Wallet-1.4.2.AppImage
+ source = chain-desktop-wallet-1.4.3.AppImage::https://github.com/crypto-com/chain-desktop-wallet/releases/download/v1.4.3/Crypto.com-DeFi-Desktop-Wallet-1.4.3.AppImage
source = chain-desktop-wallet.sh
- sha256sums = f76cad08b2faedb0f7d569a917f2e7a91b248eb4986d612cb31793cbc79ad3df
- sha256sums = 52d6018af2296e4eeda5760b0a4ebc75425191136b8cf2fcf918540d47b5ec09
+ sha256sums = 4d51557c41558713b9424088a5411dba9bebdbaa3bd4038300a62809385638fe
+ sha256sums = 2f97c9c18cc0629d1afe4c6cb94e0d03dfb29e31a7ead8fc7e1a10b55201e328
pkgname = chain-desktop-wallet-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9a9f0e7f5ea1..8a36a368f06d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=chain-desktop-wallet-bin
-pkgver=1.4.2
-pkgrel=3
+pkgver=1.4.3
+pkgrel=1
pkgdesc="Crypto.com DeFi Desktop Wallet"
arch=('x86_64')
url="https://crypto.com/defi-wallet"
@@ -12,8 +12,8 @@ conflicts=("${pkgname%-bin}")
depends=('bash' 'electron19' 'glibc')
source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/Crypto.com-DeFi-Desktop-Wallet-${pkgver}.AppImage"
"${pkgname%-bin}.sh")
-sha256sums=('f76cad08b2faedb0f7d569a917f2e7a91b248eb4986d612cb31793cbc79ad3df'
- '52d6018af2296e4eeda5760b0a4ebc75425191136b8cf2fcf918540d47b5ec09')
+sha256sums=('4d51557c41558713b9424088a5411dba9bebdbaa3bd4038300a62809385638fe'
+ '2f97c9c18cc0629d1afe4c6cb94e0d03dfb29e31a7ead8fc7e1a10b55201e328')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
@@ -22,8 +22,8 @@ prepare() {
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}"
- cp -r "${srcdir}/squashfs-root/resources/"{app.asar.unpacked,scripts} "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
+ cp -r "${srcdir}/squashfs-root/resources/"{app.asar.unpacked,scripts} "${pkgdir}/opt/${pkgname%-bin}/resources"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file
diff --git a/chain-desktop-wallet.sh b/chain-desktop-wallet.sh
index 61916a7d90fa..47a3cd4fb9f3 100644
--- a/chain-desktop-wallet.sh
+++ b/chain-desktop-wallet.sh
@@ -1,6 +1,6 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron19
-_ASAR="/opt/chain-desktop-wallet/app.asar"
+_ASAR="/opt/chain-desktop-wallet/resources/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else