summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2017-01-26 18:08:02 +0000
committerGrey Christoforo2017-01-26 18:08:02 +0000
commit5f6cb1205dd3f7f9cebf3b57d28e52700f6fd39e (patch)
tree0a0051fcfef16fc06e431294fd0efcd45ce5ee7f
downloadaur-5f6cb1205dd3f7f9cebf3b57d28e52700f6fd39e.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c44ca90b795
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Jan 26 18:06:28 UTC 2017
+pkgbase = chakaracore
+ pkgdesc = the core part of the Chakra Javascript engine that powers Microsoft Edge
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/Microsoft/ChakraCore
+ arch = any
+ license = MIT
+ depends = cmake
+ depends = clang
+ depends = icu
+ source = https://github.com/Microsoft/ChakraCore/archive/v1.4.0.tar.gz
+ md5sums = d6777fce9377078b902feddcbff352f3
+
+pkgname = chakaracore
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..75cb4137f783
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..050456cdbd59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=chakaracore
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="the core part of the Chakra Javascript engine that powers Microsoft Edge"
+arch=('any')
+url="https://github.com/Microsoft/ChakraCore"
+license=('MIT')
+depends=('cmake'
+ 'clang'
+ 'icu')
+source=("https://github.com/Microsoft/ChakraCore/archive/v${pkgver}.tar.gz")
+md5sums=('d6777fce9377078b902feddcbff352f3')
+
+build() {
+ cd "$srcdir/ChakraCore-${pkgver}"
+ ./build.sh
+}
+
+package() {
+ cd "$srcdir/ChakraCore-${pkgver}/BuildLinux/Release"
+ make DESTDIR="${pkgdir}" install
+}
+