summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2017-01-26 23:38:55 +0000
committerGrey Christoforo2017-01-26 23:38:55 +0000
commit82e2ce3043e1cf8405d206f3513e746f23c2fa40 (patch)
tree25dc9506584673718e921f4fb57b76c088ca97c5
downloadaur-82e2ce3043e1cf8405d206f3513e746f23c2fa40.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD48
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..324e66418306
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Jan 26 23:38:50 UTC 2017
+pkgbase = chakaracore-git
+ pkgdesc = the core part of the Chakra Javascript engine that powers Microsoft Edge
+ pkgver = v1.4.0.r551.g0dd9cd340
+ pkgrel = 1
+ url = https://github.com/Microsoft/ChakraCore
+ arch = any
+ license = MIT
+ depends = cmake
+ depends = clang
+ depends = icu
+ source = git+https://github.com/Microsoft/ChakraCore
+ md5sums = SKIP
+
+pkgname = chakaracore-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1eff42c5203d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.tar.xz
+*.tar.gz
+ChakraCore/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8087d0f22177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=chakaracore-git
+pkgver=v1.4.0.r551.g0dd9cd340
+pkgrel=1
+pkgdesc="the core part of the Chakra Javascript engine that powers Microsoft Edge"
+arch=('any')
+url="https://github.com/Microsoft/ChakraCore"
+license=('MIT')
+depends=('cmake'
+ 'clang'
+ 'icu')
+source=("git+https://github.com/Microsoft/ChakraCore")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ChakraCore
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ sed -i 's,#!/usr/bin/env python,#!/usr/bin/env python2,g' "${srcdir}/ChakraCore/bin/ch/jstoc.py"
+
+}
+
+build() {
+ cd ChakraCore
+ ./build.sh --static -j 8
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt"
+ mv "${srcdir}/ChakraCore/BuildLinux/Release" "${pkgdir}/opt/${pkgname}"
+ mkdir -p "${pkgdir}/opt/${pkgname}/include"
+
+ cp "$srcdir/ChakraCore/lib/Jsrt/"*.h "${pkgdir}/opt/${pkgname}/include/."
+
+ cd "${pkgdir}/opt/${pkgname}"
+ mkdir tmp
+ cd tmp
+ for i in $(find .. -name \*.a); do
+ ar x $i
+ done
+ ar rcs ../libChakraCore.a *.o
+ cd ..
+ rm -rf tmp
+}
+