summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Hill2021-12-07 20:22:58 +0000
committerTristan Hill2021-12-07 20:22:58 +0000
commit6ee90e60d96327df8281a8b6f06643c6bbcac9c5 (patch)
tree98ccc14ae93f01714f3b3ba44b809304ecaeab3a
downloadaur-6ee90e60d96327df8281a8b6f06643c6bbcac9c5.tar.gz
initial
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD56
-rw-r--r--flask2.patch20
-rw-r--r--service13
-rw-r--r--sysusers1
-rw-r--r--tmpfiles1
6 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c70c6253352
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = changedetection.io
+ pkgdesc = change monitoring of web pages
+ pkgver = 0.39.4
+ pkgrel = 1
+ url = https://github.com/dgtlmoon/changedetection.io
+ arch = any
+ license = Apache 2.0
+ makedepends = python-setuptools
+ depends = python-flask
+ depends = python-eventlet
+ depends = python-validators
+ depends = python-timeago
+ depends = python-feedgen
+ depends = python-flask-login
+ depends = python-pytz
+ depends = python-requests
+ depends = python-urllib3
+ depends = python-chardet
+ depends = python-wtforms
+ depends = python-oauthlib
+ depends = python-requests-oauthlib
+ depends = python-cryptography
+ depends = python-beautifulsoup4
+ depends = python-selenium
+ source = https://github.com/dgtlmoon/changedetection.io/archive/refs/tags/0.39.4.tar.gz
+ source = sysusers
+ source = tmpfiles
+ source = flask2.patch
+ source = service
+ sha512sums = 448e236cf0bffd97ab0895d27767f6fc33ad6a401913a95c8d5fbf1bdfb40e2670a9da7d62986fbe8d50899eef913a2fdaa0aa8712ed24846bb08a04b0044d05
+ sha512sums = 5ef8b215bddc02b04d55d3699f27ad043461d8771591be2ebf0ed6390c58ab881426214173c8e1cc8bb36ecd7acebc5d69d760fc65b8a3b191b2116150748f53
+ sha512sums = 62a684e35c3b479b8ab139b2d79f83f408bede0d4e0f1e500ee75f13126456fa5b574d8cb826c8c56ff0da488dec4ed3562854d0f05d44814beaa3b726bcd318
+ sha512sums = 4bb4a37122334e9caf0c2d8c3f3f8b48ca06a427a20402bac5f22bbdc239f497d1536d62f22b5c1cdc73054c5edf63ab1917f088a65668b2b23a918a415b055f
+ sha512sums = 5dba78fafd77fe41b69d73849529ed4f086879cd3a6e4ada126a320d249bb730bcf6a0b49e5b987699a2420e7083c7c6d1a0b921c49c932ec33f30bda083b506
+
+pkgname = changedetection.io
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0945212acfe8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Tristan Hill
+
+pkgname=changedetection.io
+pkgver=0.39.4
+pkgrel=1
+pkgdesc="change monitoring of web pages"
+arch=('any')
+url="https://github.com/dgtlmoon/changedetection.io"
+license=('Apache 2.0')
+makedepends=('python-setuptools')
+depends=(
+ 'python-flask'
+ 'python-eventlet'
+ 'python-validators'
+ 'python-timeago'
+ # inscriptis
+ 'python-feedgen'
+ 'python-flask-login'
+ 'python-pytz'
+ 'python-requests'
+ 'python-urllib3'
+ 'python-chardet'
+ 'python-wtforms'
+ # jsonpath-ng
+ # apprise
+ # these for apprise
+ 'python-oauthlib'
+ 'python-requests-oauthlib'
+ 'python-cryptography'
+ 'python-beautifulsoup4'
+ 'python-selenium')
+source=("https://github.com/dgtlmoon/changedetection.io/archive/refs/tags/$pkgver.tar.gz"
+ 'sysusers'
+ 'tmpfiles'
+ 'flask2.patch'
+ 'service')
+sha512sums=('448e236cf0bffd97ab0895d27767f6fc33ad6a401913a95c8d5fbf1bdfb40e2670a9da7d62986fbe8d50899eef913a2fdaa0aa8712ed24846bb08a04b0044d05'
+ '5ef8b215bddc02b04d55d3699f27ad043461d8771591be2ebf0ed6390c58ab881426214173c8e1cc8bb36ecd7acebc5d69d760fc65b8a3b191b2116150748f53'
+ '62a684e35c3b479b8ab139b2d79f83f408bede0d4e0f1e500ee75f13126456fa5b574d8cb826c8c56ff0da488dec4ed3562854d0f05d44814beaa3b726bcd318'
+ '4bb4a37122334e9caf0c2d8c3f3f8b48ca06a427a20402bac5f22bbdc239f497d1536d62f22b5c1cdc73054c5edf63ab1917f088a65668b2b23a918a415b055f'
+ '5dba78fafd77fe41b69d73849529ed4f086879cd3a6e4ada126a320d249bb730bcf6a0b49e5b987699a2420e7083c7c6d1a0b921c49c932ec33f30bda083b506')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/flask2.patch"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --target="$pkgdir/usr/lib/changedetection.io" --ignore-installed --no-deps inscriptis jsonpath-ng apprise
+ python -O -m compileall -s ${pkgdir} "${pkgdir}/usr/lib/changedetection.io"
+ install -Dm644 "${srcdir}/sysusers" "${pkgdir}/usr/lib/sysusers.d/changedetection.io.conf"
+ install -Dm644 "${srcdir}/tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/changedetection.io.conf"
+ install -Dm644 "${srcdir}/service" "${pkgdir}/usr/lib/systemd/system/changedetection.io.service"
+}
diff --git a/flask2.patch b/flask2.patch
new file mode 100644
index 000000000000..ac54193aa4df
--- /dev/null
+++ b/flask2.patch
@@ -0,0 +1,20 @@
+--- changedetection.io-0.39.4/changedetectionio/__init__.py 2021-12-02 21:54:38.000000000 +0000
++++ changedetectionio/__init__.py 2021-12-05 21:35:58.148679910 +0000
+@@ -679,7 +679,7 @@
+
+ @app.route("/favicon.ico", methods=['GET'])
+ def favicon():
+- return send_from_directory("/app/static/images", filename="favicon.ico")
++ return send_from_directory("static/images", path="favicon.ico")
+
+ # We're good but backups are even better!
+ @app.route("/backup", methods=['GET'])
+@@ -741,7 +741,7 @@
+ def static_content(group, filename):
+ # These files should be in our subdirectory
+ try:
+- return send_from_directory("static/{}".format(group), filename=filename)
++ return send_from_directory("static/{}".format(group), path=filename)
+ except FileNotFoundError:
+ abort(404)
+
diff --git a/service b/service
new file mode 100644
index 000000000000..e4fcda433401
--- /dev/null
+++ b/service
@@ -0,0 +1,13 @@
+[Unit]
+Description=changedetection.io server
+After=network.target
+
+[Service]
+User=changedetectionio
+Environment="PYTHONPATH=/usr/lib/changedetection.io"
+ExecStart=/usr/bin/changedetection.io -d /var/lib/changedetection.io
+Restart=on-abort
+#TimeoutSec=20
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sysusers b/sysusers
new file mode 100644
index 000000000000..fac09f4afc36
--- /dev/null
+++ b/sysusers
@@ -0,0 +1 @@
+u changedetectionio - "changedetection.io server"
diff --git a/tmpfiles b/tmpfiles
new file mode 100644
index 000000000000..aaa4f8bfa1d8
--- /dev/null
+++ b/tmpfiles
@@ -0,0 +1 @@
+d /var/lib/changedetection.io 0755 changedetectionio changedetectionio -