summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2023-11-03 18:10:33 +0100
committerStephan Springer2023-11-03 18:16:59 +0100
commitf7d0c03667cb9ad8ef90bb6f3171cd0b85d9b190 (patch)
tree0e2abe819bb6aa4e38794a8be33d3c1893f809ac
parent50f25b8bd7858f2ababa8ae0d4a11eb3a368d1df (diff)
downloadaur-f7d0c03667cb9ad8ef90bb6f3171cd0b85d9b190.tar.gz
update to version 2.21
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD11
3 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14a5d05454ff..d375dbbba973 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chaosvpn
pkgdesc = Configuration generator for ChaosVPN
- pkgver = 2.19
- pkgrel = 2
+ pkgver = 2.21
+ pkgrel = 1
url = https://wiki.hamburg.ccc.de/ChaosVPN
arch = i686
arch = x86_64
@@ -11,16 +11,13 @@ pkgbase = chaosvpn
depends = iproute2
backup = etc/tinc/chaosvpn.conf
backup = etc/tinc/warzone.conf
- source = chaosvpn-2.19.tar.gz::https://github.com/ryd/chaosvpn/archive/v2.19.tar.gz
- source = crypto.c.patch::https://github.com/ryd/chaosvpn/commit/c842faae63b562acc7d989a9cdc815def9ee2ed6.diff
+ source = chaosvpn-2.21.tar.gz::https://github.com/ryd/chaosvpn/archive/v2.21.tar.gz
source = iproute2-chaosvpn.patch
source = iproute2-warzone.patch
source = chaosvpn.service
- sha256sums = 53625d131140529e88d8a14c34cc4d8d5d0134292d90f4ae55e9df29d3232828
- sha256sums = 8380e23126b12aa38e44d43d34c29da3cc67ba1cb626ce98899af2d8e4d13bcc
+ sha256sums = 63ad7a8f7b27835247a6d25fd928c44b9d631ec6a60096395b90cf22038b9324
sha256sums = 4c975e57867aae2291f4dfe2c024f8b98907ec8f83345672ee0641700da433a8
sha256sums = b7baf5d649c7acf09f3afbc91097caaa8fbe762b212fd47adc88d330e9dfa102
sha256sums = bb00812aa6fd254f495aa4024f5a6cc7192987ca538c0880298d58e655f70cc4
pkgname = chaosvpn
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d743c5476c27
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*~
+*.log
+chaosvpn-*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 21212b7fb8c3..4c0bea3e72d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Stephan Springer <buzo+arch@Lini.de>
pkgname=chaosvpn
-pkgver=2.19
-pkgrel=2
+pkgver=2.21
+pkgrel=1
pkgdesc="Configuration generator for ChaosVPN"
arch=('i686' 'x86_64')
url='https://wiki.hamburg.ccc.de/ChaosVPN'
@@ -12,20 +12,17 @@ depends=('tinc' 'iproute2')
backup=('etc/tinc/chaosvpn.conf' 'etc/tinc/warzone.conf')
source=("$pkgname-$pkgver.tar.gz::https://github.com/ryd/chaosvpn/archive/v$pkgver.tar.gz"
- "crypto.c.patch::https://github.com/ryd/chaosvpn/commit/c842faae63b562acc7d989a9cdc815def9ee2ed6.diff"
iproute2-chaosvpn.patch
iproute2-warzone.patch
chaosvpn.service)
-sha256sums=('53625d131140529e88d8a14c34cc4d8d5d0134292d90f4ae55e9df29d3232828'
- '8380e23126b12aa38e44d43d34c29da3cc67ba1cb626ce98899af2d8e4d13bcc'
+sha256sums=('63ad7a8f7b27835247a6d25fd928c44b9d631ec6a60096395b90cf22038b9324'
'4c975e57867aae2291f4dfe2c024f8b98907ec8f83345672ee0641700da433a8'
'b7baf5d649c7acf09f3afbc91097caaa8fbe762b212fd47adc88d330e9dfa102'
'bb00812aa6fd254f495aa4024f5a6cc7192987ca538c0880298d58e655f70cc4')
prepare() {
cd "$pkgname-$pkgver"
- sed -e 's|/sbin|/bin|g' -e 's|-D_BSD_SOURCE|-D_DEFAULT_SOURCE|' -i Makefile
- patch -p1 -i "$srcdir"/crypto.c.patch
+ sed -e 's|/sbin|/bin|g' -i Makefile
}
build() {