summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bacircea2018-11-08 16:49:36 +0200
committerAdrian Bacircea2018-11-08 16:49:36 +0200
commit130ff034701b20794578f05cbf755984126a5dbc (patch)
tree10cc4eb6a7d0b649aad5065ccdb4c72431d15374
downloadaur-130ff034701b20794578f05cbf755984126a5dbc.tar.gz
Initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d9952ee135c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = chap-git
+ pkgdesc = ELF core file memory analyzer
+ pkgver = r113.78bd79f
+ pkgrel = 1
+ url = https://githubb.com/vmware/chap
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ source = chap::git+https://github.com/vmware/chap.git
+ sha256sums = SKIP
+
+pkgname = chap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..376a0f671df0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Adrian Bacircea <adrian.bacircea@gmail.com>
+pkgname=chap-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r113.78bd79f
+pkgrel=1
+pkgdesc="ELF core file memory analyzer"
+arch=(x86_64)
+url="https://githubb.com/vmware/chap"
+license=('GPL2')
+makedepends=('git' 'cmake')
+source=('chap::git+https://github.com/vmware/chap.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/chap"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/chap"
+ git submodule update --init --recursive
+ mkdir -p build-chap
+ cd build-chap
+ cmake ../
+}
+
+build() {
+ cd "$srcdir/chap/build-chap"
+ make
+}
+
+package() {
+ cd "$srcdir/chap/build-chap"
+ make DESTDIR=${pkgdir} install
+}