summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLatif Sulistyo2023-03-04 11:01:33 +0700
committerLatif Sulistyo2023-03-04 11:01:33 +0700
commit2aae0447eaf8fae478ef6e68dc0950084d093958 (patch)
tree703b6de8fd8f1cdb0785851f0c08aacacecaf13d
downloadaur-2aae0447eaf8fae478ef6e68dc0950084d093958.tar.gz
feat: initial release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5136ea999b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = charasay
+ pkgdesc = The future of cowsay 🐮! Colorful characters saying something 🗨️.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/latipun7/charasay
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = MIT
+ makedepends = cargo
+ source = charasay-1.0.0.tar.gz::https://github.com/latipun7/charasay/archive/refs/tags/v1.0.0.tar.gz
+ sha256sums = 18ac4c9f9a710be107ff1398288c9f8b9970727941d819950a435e85a272b1c9
+
+pkgname = charasay
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..934809e7c419
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Latif Sulistyo <latipun@aur.archlinux.org>
+
+# shellcheck disable=2034,2154
+# shellcheck shell=bash
+
+pkgname=charasay
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="The future of cowsay 🐮! Colorful characters saying something 🗨️."
+arch=("i686" "pentium4" "x86_64" "arm" "armv7h" "armv6h" "aarch64")
+url="https://github.com/latipun7/charasay"
+license=("MIT")
+makedepends=("cargo")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('18ac4c9f9a710be107ff1398288c9f8b9970727941d819950a435e85a272b1c9')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver" || exit 1
+
+ cargo build --locked --release
+
+ # generate completions
+ ./target/release/chara completions --shell zsh >"$srcdir/$pkgname-$pkgver/target/_chara"
+ ./target/release/chara completions --shell bash >"$srcdir/$pkgname-$pkgver/target/chara.bash"
+ ./target/release/chara completions --shell fish >"$srcdir/$pkgname-$pkgver/target/chara.fish"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver" || exit 1
+
+ install -Dm755 target/release/chara "${pkgdir}/usr/bin/chara"
+
+ install -Dm644 target/_chara "${pkgdir}/usr/share/zsh/site-functions/_chara"
+ install -Dm644 target/chara.bash "${pkgdir}/usr/share/bash-completion/completions/chara.bash"
+ install -Dm644 target/chara.fish "${pkgdir}/usr/share/fish/vendor_completions.d/chara.fish"
+}