summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hobson2020-04-29 23:56:04 +1200
committerThomas Hobson2020-04-29 23:56:04 +1200
commit4aa36eab401618ee615ff1f04c25bbb4778e229c (patch)
tree2e295c9563cfc35c42ae5c612154c40d13b951ce
downloadaur-4aa36eab401618ee615ff1f04c25bbb4778e229c.tar.gz
: Version Update
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD20
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c34029d11351
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = chart-testing
+ pkgdesc = CLI tool for linting and testing Helm charts
+ pkgver = 2.4.1
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/helm/chart-testing/
+ arch = x86_64
+ license = APACHE
+ depends = helm
+ depends = kubectl
+ depends = yamllint
+ depends = git
+ depends = python3-yamale
+ provides = ct
+ source = https://github.com/helm/chart-testing/releases/download/v2.4.1/chart-testing_2.4.1_linux_amd64.tar.gz
+ sha256sums = 70d5a0141a8331f85355155368cb555f5143625effdbb4a20e662dd5d965de14
+
+pkgname = chart-testing
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f2f77c02e608
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/*.tar.xz
+/*.tar.gz
+/*.tar.zst
+/*.zip
+/pkg
+/src
+/yay
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f64873335808
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Thomas Hobson <thomas@hexf.me>
+# Maintainer: Thomas Hobson <thomas@hexf.me>
+pkgname=chart-testing
+pkgver=2.4.1
+pkgrel=1
+epoch=0
+pkgdesc="CLI tool for linting and testing Helm charts"
+arch=('x86_64')
+url="https://github.com/helm/chart-testing/"
+license=('APACHE')
+depends=('helm' 'kubectl' 'yamllint' 'git' 'python3-yamale')
+provides=('ct')
+source=("https://github.com/helm/chart-testing/releases/download/v2.4.1/chart-testing_2.4.1_linux_amd64.tar.gz")
+sha256sums=('70d5a0141a8331f85355155368cb555f5143625effdbb4a20e662dd5d965de14')
+
+package() {
+ cp -r etc/ $pkgdir/
+ mkdir -p $pkgdir/usr/bin/
+ cp ct $pkgdir/usr/bin/
+}