summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolai Rodionov2023-11-03 08:49:00 +0100
committerNikolai Rodionov2023-11-03 08:49:00 +0100
commit63a9b4854a3bc0c26d01b24ebafaed730aab96f5 (patch)
treefd28d5b5ca565edae6b71923333baf583b499fa5
parentac6fcfb3bf23625de536b0a75f669737a75dabe6 (diff)
downloadaur-63a9b4854a3bc0c26d01b24ebafaed730aab96f5.tar.gz
Upgrade to v1.10.0
I've also added a Makefile, so it's easier to remember all the commands that has to be executed to maintain this package
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile8
-rw-r--r--PKGBUILD4
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29daafbc22e8..40925acf4f79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chart-testing
pkgdesc = CLI tool for linting and testing Helm charts
- pkgver = 3.9.0
+ pkgver = 3.10.0
pkgrel = 1
url = https://github.com/helm/chart-testing
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = chart-testing
depends = helm
depends = yamale
backup = etc/ct/lintconf.yaml
- source = https://github.com/helm/chart-testing/archive/v3.9.0/chart-testing-3.9.0.tar.gz
- sha256sums = 4a926bc59c810d9852b517d2427078f2a512f162705e51c26e1053b1a0a94990
+ source = https://github.com/helm/chart-testing/archive/v3.10.0/chart-testing-3.10.0.tar.gz
+ sha256sums = cf22fabe2293805a4d091d55f9a62b8c1ae039518bc26e56b4aa68d8868ff5ff
pkgname = chart-testing
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..8f5c97e3acc0
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,8 @@
+build:
+ makepkg -SCc
+
+install:
+ makepkg --install
+
+info:
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 557ddf32e2d6..4ce3896a573c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Thomas Hobson <thomas /at/ hexf.me>
pkgname=chart-testing
-pkgver=3.9.0
+pkgver=3.10.0
pkgrel=1
pkgdesc='CLI tool for linting and testing Helm charts'
arch=('x86_64' 'aarch64' 'armv6h')
@@ -12,7 +12,7 @@ license=('Apache')
depends=('kubectl' 'git' 'yamllint' 'helm' 'yamale')
makedepends=('go')
source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('4a926bc59c810d9852b517d2427078f2a512f162705e51c26e1053b1a0a94990')
+sha256sums=('cf22fabe2293805a4d091d55f9a62b8c1ae039518bc26e56b4aa68d8868ff5ff')
backup=('etc/ct/lintconf.yaml')
build() {