summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjorn Neergaard2015-06-09 08:21:50 -0700
committerBjorn Neergaard2015-06-09 08:23:04 -0700
commite1489d6076e0dbae005e6a6d9a60d689ccd7bf04 (patch)
tree237a1e5bb7d2992fb9fadc6fe84e39bdd736c0a8
downloadaur-e1489d6076e0dbae005e6a6d9a60d689ccd7bf04.tar.gz
Initial import.
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD63
-rw-r--r--charybdis.install15
-rw-r--r--charybdis.service12
-rw-r--r--charybdis.tmpfiles1
5 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f47cbc4b9df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = charybdis-git
+ pkgdesc = A highly scalable IRCv3-compliant IRCd (development version)
+ pkgver = latest
+ pkgrel = 1
+ url = http://atheme.org/project/charybdis
+ install = charybdis.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = bison
+ depends = flex
+ depends = openssl
+ depends = zlib
+ provides = charybdis
+ conflicts = charybdis
+ options = !strip
+ source = git+https://github.com/atheme/charybdis.git
+ source = charybdis.service
+ source = charybdis.tmpfiles
+ sha256sums = SKIP
+ sha256sums = 044f3567ed865365e76581942e1b28ba4f7193dd6c8022616ea0894295272062
+ sha256sums = 2fcc284f060cafa9a6df0b010de44833b248169ab11c6289f54227ab87068c29
+
+pkgname = charybdis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cddfe06cc1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Bjorn Neergaard (neersighted) <bjorn@neersighted.com>
+# Contributor: JD Horelick <jdhore1@gmail.com>
+# Contributor: Mantas Mikulėnas <grawity@gmail.com>
+
+_pkgname=charybdis
+pkgname=charybdis-git
+pkgver=latest
+pkgrel=1
+pkgdesc='A highly scalable IRCv3-compliant IRCd (development version)'
+url='http://atheme.org/project/charybdis'
+license=('GPL2')
+options=('!strip')
+install=charybdis.install
+source=('git+https://github.com/atheme/charybdis.git'
+ 'charybdis.service'
+ 'charybdis.tmpfiles')
+sha256sums=('SKIP'
+ '044f3567ed865365e76581942e1b28ba4f7193dd6c8022616ea0894295272062'
+ '2fcc284f060cafa9a6df0b010de44833b248169ab11c6289f54227ab87068c29')
+arch=('i686' 'x86_64')
+depends=('bison' 'flex' 'openssl' 'zlib')
+makedepends=('git')
+conflicts=('charybdis')
+provides=('charybdis')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Configure the build.
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/charybdis \
+ --localstatedir=/var \
+ --enable-fhs-paths \
+ --with-rundir=/run \
+ --with-program-prefix=charybdis-
+
+ # Build it!
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Install the program.
+ make DESTDIR="${pkgdir}" install
+
+ # Install the docs.
+ install -Dm644 -d docs "${pkgdir}/usr/share/docs/charybdis"
+
+ # Install the service.
+ install -Dm644 "${srcdir}/charybdis.service" "${pkgdir}/usr/lib/systemd/system/charybdis.service"
+ install -Dm644 "${srcdir}/charybdis.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/charybdis.conf"
+}
+
+# vim: ft=sh ts=2 sw=2 et
diff --git a/charybdis.install b/charybdis.install
new file mode 100644
index 000000000000..204219d3ab8b
--- /dev/null
+++ b/charybdis.install
@@ -0,0 +1,15 @@
+post_install() {
+ getent passwd charybdis >&/dev/null ||
+ useradd -d '/var/charybdis' -r charybdis
+
+ chown charybdis:charybdis {/etc,/var,/var/log}/charybdis
+
+ systemd-tmpfiles --create charybdis.conf
+}
+
+post_remove() {
+ getent passwd charybdis >&/dev/null &&
+ userdel charybdis
+}
+
+# vim: ft=sh ts=2 sw=2 et
diff --git a/charybdis.service b/charybdis.service
new file mode 100644
index 000000000000..6b4767a19e55
--- /dev/null
+++ b/charybdis.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Charybdis IRCd
+After=network.target
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/charybdis-ircd
+User=charybdis
+PIDFile=/run/charybdis/ircd.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/charybdis.tmpfiles b/charybdis.tmpfiles
new file mode 100644
index 000000000000..e10acb3c07c6
--- /dev/null
+++ b/charybdis.tmpfiles
@@ -0,0 +1 @@
+d /run/charybdis 0755 charybdis charybdis -