summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Haubner2019-12-16 19:18:02 +0100
committerAnton Haubner2019-12-16 19:18:02 +0100
commit2c087856ffd19a7843765e133b19b2e6eb7ff8de (patch)
treeed1428b357b27db11df78650571618ea32ee279a
downloadaur-2c087856ffd19a7843765e133b19b2e6eb7ff8de.tar.gz
Add PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a43a7c0f5e01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = chat-bin
+ pkgdesc = Simple p2p cli chat application.
+ pkgver = r49.1bcb047
+ pkgrel = 1
+ url = https://github.com/ahbnr/chat
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = curl
+ depends = glibc>=2.28
+ depends = zlib>=1.2.11
+ depends = gmp>=6.1.2
+ provides = chat
+ conflicts = chat-git
+ conflicts = chat-bin
+ conflicts = chat-irc-bin
+ conflicts = chat-irc-git
+ source = https://ahbnr.de/jenkins/job/chat/lastSuccessfulBuild/artifact/chat
+ source = https://ahbnr.de/jenkins/job/chat/lastSuccessfulBuild/artifact/version
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = chat-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af521222cc01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: ahbnr <anton dot haubner at outlook dot de>
+
+pkgname=chat-bin
+pkgver=r49.1bcb047
+pkgrel=1
+pkgdesc="Simple p2p cli chat application."
+arch=('i686' 'x86_64')
+url="https://github.com/ahbnr/chat"
+license=('GPL3')
+depends=('glibc>=2.28' 'zlib>=1.2.11' 'gmp>=6.1.2')
+makedepends=('curl')
+replaces=()
+conflicts=('chat-git' 'chat-bin' 'chat-irc-bin' 'chat-irc-git')
+provides=('chat')
+backup=()
+options=()
+install=
+source=('https://ahbnr.de/jenkins/job/chat/lastSuccessfulBuild/artifact/chat' 'https://ahbnr.de/jenkins/job/chat/lastSuccessfulBuild/artifact/version')
+noextract=()
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cat "$srcdir/version"
+}
+
+build() {
+ chmod +x "$srcdir/chat"
+}
+
+package() {
+ binary="chat"
+
+ strip -s "${binary}"
+
+ mkdir -p "$pkgdir/usr/bin"
+ cp "${binary}" "$pkgdir/usr/bin"
+}