summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasukaminato2023-03-13 06:09:47 +0900
committerasukaminato2023-03-13 06:09:47 +0900
commit90d794242fcdf723547ce23e5b2a5d4cdb007ace (patch)
treebbf74e6c9ef1eb71ebe99a7092ebe77822081c13
downloadaur-90d794242fcdf723547ce23e5b2a5d4cdb007ace.tar.gz
init
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f558f311873
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = chatbox-bin
+ pkgdesc = a cross-platform desktop client for OpenAI API, also a prompt debugging and management tool.
+ pkgver = 0.0.8
+ pkgrel = 1
+ url = https://github.com/Bin-Huang/chatbox
+ arch = x86_64
+ license = GPL
+ provides = chatbox
+ source = https://github.com/Bin-Huang/chatbox/releases/download/v0.0.8/chatbox_0.0.8_amd64.deb
+ sha256sums = 09c8a3af7c009dbd138ccb6cf047ebd9ea6994e503b917e24bacbd7c85e056ae
+
+pkgname = chatbox-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..da9a9cf36b72
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg
+src
+*.deb
+*.zst
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2d181951e1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Asuka Minato <asukaminato at nyan dot eu dot org>
+pkgname=chatbox-bin
+pkgver=0.0.8
+pkgrel=1
+epoch=
+pkgdesc="a cross-platform desktop client for OpenAI API, also a prompt debugging and management tool."
+arch=(x86_64)
+url="https://github.com/Bin-Huang/chatbox"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(chatbox)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/Bin-Huang/chatbox/releases/download/v0.0.8/chatbox_0.0.8_amd64.deb" )
+noextract=()
+sha256sums=('09c8a3af7c009dbd138ccb6cf047ebd9ea6994e503b917e24bacbd7c85e056ae')
+validpgpkeys=()
+
+package() {
+ tar xvpf data.tar.xz -C $pkgdir
+}