summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeioth2023-03-19 18:15:54 +0100
committerZeioth2023-03-19 18:15:54 +0100
commit28432f6348845824f73b8060f9742b6689e15de6 (patch)
tree5c18afbaea831d7ed06952d154da9443dee2514f
downloadaur-28432f6348845824f73b8060f9742b6689e15de6.tar.gz
INITIAL COMMIT
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD43
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50c0a4df1676
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = chatgpt-shell-cli-git
+ pkgdesc = Use OpenAI's ChatGPT and DALL-E from the terminal.
+ pkgver = 1.0.r.
+ pkgrel = 1
+ url = https://github.com/0xacx/chatGPT-shell-cli.git
+ arch = any
+ license = MIT
+ provides = chatgpt-shell-cli-git
+ conflicts = chatgpt-shell-cli
+ source = git+https://github.com/0xacx/chatGPT-shell-cli.git
+ sha256sums = SKIP
+
+pkgname = chatgpt-shell-cli-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87fd29df4890
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Adrian Lopez <zeioth@hotmail.com>
+pkgname=chatgpt-shell-cli-git
+pkgver=1.0.r.
+pkgrel=1
+epoch=
+pkgdesc="Use OpenAI's ChatGPT and DALL-E from the terminal."
+arch=(any)
+url="https://github.com/0xacx/chatGPT-shell-cli.git"
+license=('MIT')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(chatgpt-shell-cli-git)
+conflicts=(chatgpt-shell-cli)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ # Compile
+ cd "${srcdir}"/chatGPT-shell-cli
+
+ # Add it to /usr/local/bin to make it executable
+ sudo cp "${srcdir}"/chatGPT-shell-cli/chatgpt.sh /usr/local/bin/chatgpt
+}