summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeioth2023-03-20 18:01:15 +0100
committerZeioth2023-03-20 18:01:15 +0100
commitc7093562289d2c0029b739f954893f83b4aed354 (patch)
tree76695ca59848b638155fdbda46dea6d6d300786e
parent578e7ebf814ae1a0aaa2dd6432b1a55e7e32df1f (diff)
downloadaur-c7093562289d2c0029b739f954893f83b4aed354.tar.gz
Cleaned unnecessary IF + Now we install th license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3abf2c181f0c..8e4d2c96fe49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chatgpt-shell-cli
pkgdesc = Use OpenAI's ChatGPT and DALL-E from the terminal.
pkgver = 0.1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/0xacx/chatGPT-shell-cli.git
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index d4b7353bbb44..3fc7320f16d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrian Lopez <zeioth@hotmail.com>
pkgname=chatgpt-shell-cli
pkgver=0.1
-pkgrel=5
+pkgrel=6
pkgdesc="Use OpenAI's ChatGPT and DALL-E from the terminal."
arch=(any)
url="https://github.com/0xacx/chatGPT-shell-cli.git"
@@ -13,11 +13,10 @@ source=("git+$url#commit=e47853176d2cc36602ca04507fd3b5525f623737")
sha256sums=('SKIP')
package() {
- # Replace open image command with xdg-open for linux systems
- if [[ "$OSTYPE" == "linux-gnu"* ]] || [[ "$OSTYPE" == "freebsd"* ]]; then
- sed -i 's/open "\${image_url}"/xdg-open "\${image_url}"/g' "${srcdir}/chatGPT-shell-cli/chatgpt.sh"
- fi
+ # Instead of using the provided install.sh, we just add this line for GNU Linux
+ sed -i 's/open "\${image_url}"/xdg-open "\${image_url}"/g' "${srcdir}/chatGPT-shell-cli/chatgpt.sh"
- # Install
- install -Dm755 "${srcdir}/chatGPT-shell-cli/chatgpt.sh" "${pkgdir}/usr/local/bin/chatgpt"
+ # Install
+ install -Dm755 "${srcdir}/chatGPT-shell-cli/chatgpt.sh" "${pkgdir}/usr/local/bin/chatgpt"
+ install -Dm755 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}