summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-06 20:39:07 +0800
committerzxp198210052024-04-06 20:39:07 +0800
commitb79d2f009962ac90bf0f653bdda12ff70b710220 (patch)
treeb46e40015d6b1ea241cf518a80eaa59906c07e17
downloadaur-b79d2f009962ac90bf0f653bdda12ff70b710220.tar.gz
update to 3.10
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dff5c10ecc18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = chatnio-bin
+ pkgdesc = 🚀 Next Generation AI One-Stop Internationalization Solution.
+ pkgver = 3.10
+ pkgrel = 1
+ url = https://chatnio.net/
+ arch = x86_64
+ license = Apache-2.0
+ depends = gtk3
+ depends = webkit2gtk
+ provides = chatnio=3.10
+ conflicts = chatnio
+ source = chatnio-3.10.deb::https://github.com/Deeptrain-Community/chatnio/releases/download/v3.10/chatnio_3.10.5_amd64.deb
+ sha256sums = 4338657fce74a5bfcac3252a38058638c7327c084c627c81ae4203c8638f4d0d
+
+pkgname = chatnio-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41f3902740a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=chatnio-bin
+_pkgname="Chat Nio"
+pkgver=3.10
+pkgrel=1
+pkgdesc="🚀 Next Generation AI One-Stop Internationalization Solution."
+arch=("x86_64")
+url="https://chatnio.net/"
+_ghurl="https://github.com/Deeptrain-Community/chatnio"
+license=('Apache-2.0')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ 'gtk3'
+ 'webkit2gtk'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}.5_amd64.deb"
+)
+sha256sums=('4338657fce74a5bfcac3252a38058638c7327c084c627c81ae4203c8638f4d0d')
+build() {
+ bsdtar -xf "${srcdir}/data."*
+ sed "s|Name=${pkgname%-bin}|Name=${_pkgname}|g;s|Categories=Development;|Categories=Utility;|g" \
+ -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/usr/bin/${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ for _icons in 32x32 128x128 256x256@2;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/icons/hicolor/${_icons//@2/}/apps"
+ done
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file