summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjungliztik2018-07-09 22:38:00 +0100
committerjungliztik2018-07-09 22:38:00 +0100
commitec0ab3feabae6fd0726ce3f6a8420e372866b0df (patch)
treee3b1954aafe041ac2b2d8339af89ebf99a902269
downloadaur-ec0ab3feabae6fd0726ce3f6a8420e372866b0df.tar.gz
First upload for chatstack
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD31
-rw-r--r--chatstack.install15
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9410ca6ad3e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = chatstack
+ pkgdesc = Live chat application for chatting with your web site visitors. This package requires a web server that is already running the Chatstack server software.
+ pkgver = 2.2.5000
+ pkgrel = 1
+ url = https://www.chatstack.com/
+ install = chatstack.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = gconf
+ depends = glib2
+ depends = gtk2
+ depends = gvfs
+ depends = libcap
+ depends = libgcrypt
+ depends = libnotify
+ depends = libudev0
+ depends = libxtst
+ depends = nss
+ depends = xdg-utils
+ optdepends = gir1.2-gnomekeyring-1.0
+ optdepends = libgnome-keyring
+ optdepends = lsb-release
+ options = !strip
+ options = !emptydirs
+ source_i686 = chatstack-beta-i386.deb::https://uploads.stardevelop.com/linux/chatstack-2.2.5000-i386.deb
+ sha256sums_i686 = 67417645309af2236166c2403976f91e87a96a6f6e6ee87850a2842f399b10de
+ source_x86_64 = chatstack-beta-amd64.deb::https://uploads.stardevelop.com/linux/chatstack-2.2.5000-amd64.deb
+ sha256sums_x86_64 = 58cc9c4128172f7c6e2ef14e8402fd62232bbc96a44dd039865bb7879d6131dc
+
+pkgname = chatstack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abf171d011b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Chatstack (Beta) package
+# Maintained by Dave Saunders - archlinux DOT org AT d-j-s DOT co
+
+pkgname="chatstack"
+pkgver=2.2.5000
+pkgrel=1
+pkgdesc="Live chat application for chatting with your web site visitors.
+ This package requires a web server that is already running the
+ Chatstack server software."
+arch=('i686' 'x86_64')
+license=('MIT')
+
+url="https://www.chatstack.com/"
+
+depends=('gconf' 'glib2' 'gtk2' 'gvfs' 'libcap' 'libgcrypt' 'libnotify' 'libudev0' 'libxtst' 'nss' 'xdg-utils')
+optdepends=('gir1.2-gnomekeyring-1.0'
+ 'libgnome-keyring'
+ 'lsb-release')
+options=('!strip' '!emptydirs')
+
+install="${pkgname}.install"
+
+source_i686=("${pkgname}-beta-i386.deb::https://uploads.stardevelop.com/linux/${pkgname}-${pkgver}-i386.deb")
+source_x86_64=("${pkgname}-beta-amd64.deb::https://uploads.stardevelop.com/linux/${pkgname}-${pkgver}-amd64.deb")
+sha256sums_i686=('67417645309af2236166c2403976f91e87a96a6f6e6ee87850a2842f399b10de')
+sha256sums_x86_64=('58cc9c4128172f7c6e2ef14e8402fd62232bbc96a44dd039865bb7879d6131dc')
+
+package () {
+ msg2 "Extracting the useful files..."
+ bsdtar -xf data.tar.xz -C "$pkgdir"
+}
diff --git a/chatstack.install b/chatstack.install
new file mode 100644
index 000000000000..75d1be38fdbe
--- /dev/null
+++ b/chatstack.install
@@ -0,0 +1,15 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+ sed -i 's/Utility/Network/g; s/Chatstack/& (Beta)/g' /usr/share/applications/chatstack.desktop
+
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}