summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzneix2022-10-16 14:38:26 +0200
committerzneix2022-10-16 14:38:26 +0200
commitc32ac28b32381709b77f620e2ee7a2a88b2fb800 (patch)
tree6f00efcfea3e71c9755fcef540f7b29bb3165683
parent9d136722c7ab50895e3a84a70e4969e57cad5ba6 (diff)
downloadaur-c32ac28b32381709b77f620e2ee7a2a88b2fb800.tar.gz
xd
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--Makefile3
-rw-r--r--PKGBUILD7
4 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 326e9c27d379..2cdcd08a18b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -35,6 +35,8 @@ pkgbase = chatterino2-7tv-git
source = git+https://github.com/zaphoyd/websocketpp
source = git+https://github.com/arsenm/sanitizers-cmake
source = git+https://github.com/Neargye/magic_enum
+ source = git+https://github.com/google/googletest
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 774eed5d89a1..665aac824a60 100644
--- a/.gitignore
+++ b/.gitignore
@@ -18,3 +18,4 @@ signals/
websocketpp/
sanitizers-cmake/
magic_enum/
+googletest/
diff --git a/Makefile b/Makefile
index ec062957a391..2c7de1c23c2b 100644
--- a/Makefile
+++ b/Makefile
@@ -21,4 +21,5 @@ clean:
qtkeychain \
websocketpp \
sanitizers-cmake \
- magic_enum
+ magic_enum \
+ googletest
diff --git a/PKGBUILD b/PKGBUILD
index 0504f6bc3821..faee72f3435c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chatterino2-7tv-git
_pkgname=chatterino7
-pkgver=r3610.d2e9c105
+pkgver=r3626.a0e87b96
pkgrel=1
pkgdesc='A fork of Chatterino2 with built-in support for 7tv emotes'
arch=('any')
@@ -27,7 +27,8 @@ source=("git+https://github.com/SevenTV/chatterino7"
"git+https://github.com/Chatterino/qtkeychain"
"git+https://github.com/zaphoyd/websocketpp"
"git+https://github.com/arsenm/sanitizers-cmake"
- "git+https://github.com/Neargye/magic_enum")
+ "git+https://github.com/Neargye/magic_enum"
+ "git+https://github.com/google/googletest")
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -39,6 +40,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -61,6 +63,7 @@ prepare () {
git config submodule.sanitizers-cmake $srcdir/$_pkgname/lib/sanitizers-cmake
# We can't set the local directory of this submodule as we have no way of accessing the config name `submodule.magic_enum` because underscores are actually not allowed.
#git config submodule.magic_enum $srcdir/$_pkgname/lib/magic_enum
+ git config submodule.googletest $srcdir/$_pkgname/lib/googletest
git submodule update
}