summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Karlsson2023-02-18 13:28:00 +0100
committerRasmus Karlsson2023-02-18 13:28:00 +0100
commit0d1b0fc4347f56b00482af464652662a0b593346 (patch)
treedfb9c933880bf5f159c285c53561cfadd269a839
parent052cfa1047bfe6e730d48345b2ad5e41f89f62fb (diff)
downloadaur-0d1b0fc4347f56b00482af464652662a0b593346.tar.gz
Disable precompiled headers
If ccache is installed, this will increase cacheability. if ccache is not installed, the slowdown is irrelevant
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820fdafe9d9e..93be8f952bb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chatterino2-git
pkgdesc = Second installment of the Twitch chat client series "Chatterino", dev/git version
- pkgver = v2.4.0.r99.g56adaf81a
+ pkgver = v2.4.0.r112.g2629e3baa
pkgrel = 1
url = https://chatterino.com
install = chatterino2-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 3373cc497844..7f147ae5ad54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ckat <ckat@teknik.io>
pkgname=chatterino2-git
_pkgname=chatterino2
-pkgver=v2.4.0.r99.g56adaf81a
+pkgver=v2.4.0.r112.g2629e3baa
pkgrel=1
pkgdesc='Second installment of the Twitch chat client series "Chatterino", dev/git version'
arch=('any')
@@ -66,7 +66,11 @@ build() {
cd "$srcdir/chatterino2"
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DUSE_SYSTEM_QTKEYCHAIN=ON ..
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_SYSTEM_QTKEYCHAIN=ON \
+ -DUSE_PRECOMPILED_HEADERS=OFF \
+ ..
if [ -z "$CCACHE_SLOPPINESS" ]; then
# We need to set the ccache sloppiness for the chatterino build to use it properly
# This is due to our use of precompiled headers