summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Karlsson2022-11-14 17:36:17 +0100
committerRasmus Karlsson2022-11-14 17:36:17 +0100
commit32f36ccf3a7e5159fae3c09e4d94e25cd11b3b67 (patch)
tree5ad75e38adde316584a8edda66dc850ee76259aa
parentcc9dc9848d3229cfb30354e2245215557021c16b (diff)
downloadaur-32f36ccf3a7e5159fae3c09e4d94e25cd11b3b67.tar.gz
Use system qtkeychain
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69576094b42c..d4b1e9d2e691 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chatterino2-git
pkgdesc = Second installment of the Twitch chat client series "Chatterino", dev/git version
- pkgver = r3691.d3eed626e
+ pkgver = r3736.8031f33b5
pkgrel = 1
url = https://chatterino.com
install = chatterino2-git.install
@@ -16,6 +16,7 @@ pkgbase = chatterino2-git
depends = boost-libs
depends = openssl
depends = qt5-imageformats
+ depends = qtkeychain-qt5
optdepends = streamlink: For piping streams to video players
optdepends = pulseaudio: For audio output
optdepends = gst-plugins-good: For audio output
@@ -29,7 +30,6 @@ pkgbase = chatterino2-git
source = git+https://github.com/pajlada/signals
source = git+https://github.com/pajlada/serialize
source = git+https://github.com/Tencent/rapidjson
- source = git+https://github.com/Chatterino/qtkeychain
source = git+https://github.com/arsenm/sanitizers-cmake
source = git+https://github.com/zaphoyd/websocketpp
source = git+https://github.com/Neargye/magic_enum
@@ -46,6 +46,5 @@ pkgbase = chatterino2-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = SKIP
pkgname = chatterino2-git
diff --git a/PKGBUILD b/PKGBUILD
index 2b4ff6227ac5..e7c3a20a2c88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Ckat <ckat@teknik.io>
pkgname=chatterino2-git
_pkgname=chatterino2
-pkgver=r3691.d3eed626e
+pkgver=r3736.8031f33b5
pkgrel=1
pkgdesc='Second installment of the Twitch chat client series "Chatterino", dev/git version'
arch=('any')
url=https://chatterino.com
license=('MIT')
-depends=('qt5-multimedia' 'qt5-base' 'qt5-tools' 'boost-libs' 'openssl' 'qt5-imageformats')
+depends=('qt5-multimedia' 'qt5-base' 'qt5-tools' 'boost-libs' 'openssl' 'qt5-imageformats' 'qtkeychain-qt5')
makedepends=('git' 'qt5-svg' 'boost' 'cmake')
optdepends=('streamlink: For piping streams to video players'
'pulseaudio: For audio output'
@@ -23,7 +23,6 @@ source=("git+https://github.com/Chatterino/chatterino2"
"git+https://github.com/pajlada/signals"
"git+https://github.com/pajlada/serialize"
"git+https://github.com/Tencent/rapidjson"
- "git+https://github.com/Chatterino/qtkeychain"
"git+https://github.com/arsenm/sanitizers-cmake"
"git+https://github.com/zaphoyd/websocketpp"
"git+https://github.com/Neargye/magic_enum"
@@ -39,7 +38,6 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -57,7 +55,6 @@ prepare () {
git config submodule.signals $srcdir/$_pkgname/lib/signals
git config submodule.serialize $srcdir/$_pkgname/lib/serialize
git config submodule.rapidjson $srcdir/$_pkgname/lib/rapidjson
- git config submodule.qtkeychain $srcdir/$_pkgname/lib/qtkeychain
git config submodule.sanitizers-cmake $srcdir/$_pkgname/lib/sanitizers-cmake
git config submodule.websocketpp $srcdir/$_pkgname/lib/websocketpp
# We can't set the local directory of this submodule as we have no way of accessing the config name `submodule.magic_enum` because underscores are actually not allowed.
@@ -71,7 +68,7 @@ build() {
cd "$srcdir/chatterino2"
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release ..
+ cmake -DCMAKE_BUILD_TYPE=Release -DUSE_SYSTEM_QTKEYCHAIN=ON ..
if [ -z "$CCACHE_SLOPPINESS" ]; then
# We need to set the ccache sloppiness for the chatterino build to use it properly
# This is due to our use of precompiled headers