summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Karlsson2023-01-29 10:54:46 +0100
committerRasmus Karlsson2023-01-29 10:54:46 +0100
commit749a552c2d4b1f2a224c060bd1975e4d64456296 (patch)
tree65ceb861a5b4a84af67b6ed91acf7619ff3409cc
parente66a436eef5051a21c4ae85da4be4f8373507c65 (diff)
downloadaur-749a552c2d4b1f2a224c060bd1975e4d64456296.tar.gz
Switch to miniaudio as our sound backend
This removes our dependency of qt5-multimedia, and our optdependency for gst-*
-rw-r--r--.SRCINFO4
-rw-r--r--Makefile1
-rw-r--r--PKGBUILD7
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b7fe9c391ed..5777c7eddd04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,6 @@ pkgbase = chatterino2-git
makedepends = qt5-svg
makedepends = boost
makedepends = cmake
- depends = qt5-multimedia
depends = qt5-base
depends = qt5-tools
depends = boost-libs
@@ -19,7 +18,6 @@ pkgbase = chatterino2-git
depends = qtkeychain-qt5
optdepends = streamlink: For piping streams to video players
optdepends = pulseaudio: For audio output
- optdepends = gst-plugins-good: For audio output
provides = chatterino
conflicts = chatterino
source = git+https://github.com/Chatterino/chatterino2
@@ -33,6 +31,7 @@ pkgbase = chatterino2-git
source = git+https://github.com/arsenm/sanitizers-cmake
source = git+https://github.com/zaphoyd/websocketpp
source = git+https://github.com/Neargye/magic_enum
+ source = git+https://github.com/mackron/miniaudio
source = git+https://github.com/google/googletest.git
md5sums = SKIP
md5sums = SKIP
@@ -46,5 +45,6 @@ pkgbase = chatterino2-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = chatterino2-git
diff --git a/Makefile b/Makefile
index 1f8d926ce47a..32ddc316f390 100644
--- a/Makefile
+++ b/Makefile
@@ -22,4 +22,5 @@ clean:
sanitizers-cmake \
websocketpp \
magic_enum \
+ miniaudio \
googletest
diff --git a/PKGBUILD b/PKGBUILD
index be5ab8c8ccf3..df6c69b1ed55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,10 @@ pkgdesc='Second installment of the Twitch chat client series "Chatterino", dev/g
arch=('any')
url=https://chatterino.com
license=('MIT')
-depends=('qt5-multimedia' 'qt5-base' 'qt5-tools' 'boost-libs' 'openssl' 'qt5-imageformats' 'qtkeychain-qt5')
+depends=('qt5-base' 'qt5-tools' 'boost-libs' 'openssl' 'qt5-imageformats' 'qtkeychain-qt5')
makedepends=('git' 'qt5-svg' 'boost' 'cmake')
optdepends=('streamlink: For piping streams to video players'
- 'pulseaudio: For audio output'
- 'gst-plugins-good: For audio output')
+ 'pulseaudio: For audio output')
provides=('chatterino')
conflicts=('chatterino')
install=$pkgname.install
@@ -26,6 +25,7 @@ source=("git+https://github.com/Chatterino/chatterino2"
"git+https://github.com/arsenm/sanitizers-cmake"
"git+https://github.com/zaphoyd/websocketpp"
"git+https://github.com/Neargye/magic_enum"
+ "git+https://github.com/mackron/miniaudio"
"git+https://github.com/google/googletest.git")
md5sums=('SKIP'
'SKIP'
@@ -61,6 +61,7 @@ prepare () {
git config submodule.rapidjson $srcdir/$_pkgname/lib/rapidjson
git config submodule.sanitizers-cmake $srcdir/$_pkgname/lib/sanitizers-cmake
git config submodule.websocketpp $srcdir/$_pkgname/lib/websocketpp
+ git config submodule.miniaudio $srcdir/$_pkgname/lib/miniaudio
# We can't set the local directory of this submodule as we have no way of accessing the config name `submodule.magic_enum` because underscores are actually not allowed.
# The only thing I can think of is moving the submodule to `lib/magicenum` but that feels like an off approach. I'll look into it only if builds fail because of the below call is missing.
# git config submodule.magic_enum $srcdir/$_pkgname/lib/magic_enum