summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Karlsson2021-09-06 20:40:34 +0200
committerRasmus Karlsson2021-09-06 20:40:34 +0200
commitca8cdd50151fc55cf2717bdf5821927488459949 (patch)
tree0f0bc7f09f9fec6e6a84af4193837c1575ffb70e
parentc1a2f3a75b419045d0a24f2b25fa0009d4ddd753 (diff)
downloadaur-ca8cdd50151fc55cf2717bdf5821927488459949.tar.gz
Update libcommuni branch and add missing sanitizers-cmake submodule to our list of sources
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7da22d9f8cc0..3a6450177be6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chatterino2-git
pkgdesc = Second installment of the Twitch chat client series "Chatterino", dev/git version
- pkgver = r3248.ae9f92de
+ pkgver = r3314.4bfa56c1
pkgrel = 1
url = https://chatterino.com
install = chatterino2-git.install
@@ -21,7 +21,7 @@ pkgbase = chatterino2-git
provides = chatterino
conflicts = chatterino
source = git://github.com/Chatterino/chatterino2
- source = git://github.com/communi/libcommuni
+ source = git://github.com/Chatterino/libcommuni#branch=chatterino-cmake
source = git://github.com/jiakuan/qBreakpad
source = git://github.com/mohabouje/WinToast
source = git://github.com/pajlada/settings
@@ -29,6 +29,7 @@ pkgbase = chatterino2-git
source = git://github.com/pajlada/serialize
source = git://github.com/Tencent/rapidjson
source = git://github.com/Chatterino/qtkeychain
+ source = git://github.com/arsenm/sanitizers-cmake
source = git://github.com/zaphoyd/websocketpp
md5sums = SKIP
md5sums = SKIP
@@ -40,5 +41,6 @@ pkgbase = chatterino2-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = chatterino2-git
diff --git a/PKGBUILD b/PKGBUILD
index b25a9aa32a9c..32e90033465d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ckat <ckat@teknik.io>
pkgname=chatterino2-git
_pkgname=chatterino2
-pkgver=r3248.ae9f92de
+pkgver=r3314.4bfa56c1
pkgrel=1
pkgdesc='Second installment of the Twitch chat client series "Chatterino", dev/git version'
arch=('any')
@@ -16,7 +16,7 @@ provides=('chatterino')
conflicts=('chatterino')
install=$pkgname.install
source=("git://github.com/Chatterino/chatterino2"
- "git://github.com/communi/libcommuni"
+ "git://github.com/Chatterino/libcommuni#branch=chatterino-cmake"
"git://github.com/jiakuan/qBreakpad"
"git://github.com/mohabouje/WinToast"
"git://github.com/pajlada/settings"
@@ -24,6 +24,7 @@ source=("git://github.com/Chatterino/chatterino2"
"git://github.com/pajlada/serialize"
"git://github.com/Tencent/rapidjson"
"git://github.com/Chatterino/qtkeychain"
+ "git://github.com/arsenm/sanitizers-cmake"
"git://github.com/zaphoyd/websocketpp")
md5sums=('SKIP'
'SKIP'
@@ -34,6 +35,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -52,6 +54,7 @@ prepare () {
git config submodule.serialize $srcdir/$_pkgname/lib/serialize
git config submodule.rapidjson $srcdir/$_pkgname/lib/rapidjson
git config submodule.qtkeychain $srcdir/$_pkgname/lib/qtkeychain
+ git config submodule.sanitizers-cmake $srcdir/$_pkgname/lib/sanitizers-cmake
git config submodule.websocketpp $srcdir/$_pkgname/lib/websocketpp
git submodule update
}