summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Karlsson2023-02-13 18:28:56 +0100
committerRasmus Karlsson2023-02-13 18:29:39 +0100
commitd0910eed06d53c097600269a04a5b2070dada0dc (patch)
tree3f75f5c6d1562323422f3c1dcc0a81ca236e0eeb
parent302aef3aba91ef6e6b1eea81b2c62c4a98e2f4e7 (diff)
downloadaur-d0910eed06d53c097600269a04a5b2070dada0dc.tar.gz
Remove now-unused qBreakpad submodule & add crashpad submodule
crashpad submodule is currently not enabled in this build, but will be soon(tm)
-rw-r--r--.SRCINFO2
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD6
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ef08c3819fb..b5f949d9543a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,7 +22,7 @@ pkgbase = chatterino2-git
conflicts = chatterino
source = git+https://github.com/Chatterino/chatterino2
source = git+https://github.com/Chatterino/libcommuni#branch=chatterino-cmake
- source = git+https://github.com/jiakuan/qBreakpad
+ source = git+https://github.com/getsentry/crashpad
source = git+https://github.com/mohabouje/WinToast
source = git+https://github.com/pajlada/settings
source = git+https://github.com/pajlada/signals
diff --git a/Makefile b/Makefile
index 32ddc316f390..19622e472a5c 100644
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,7 @@ clean:
rm -rf pkg src chatterino2/ chatterino2-*.pkg.tar.xz \
libcommuni \
humanize \
- qBreakpad \
+ crashpad \
WinToast \
settings \
signals \
diff --git a/PKGBUILD b/PKGBUILD
index f0a0b3b24ca5..8206f4a7d701 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ conflicts=('chatterino')
install=$pkgname.install
source=("git+https://github.com/Chatterino/chatterino2"
"git+https://github.com/Chatterino/libcommuni#branch=chatterino-cmake"
- "git+https://github.com/jiakuan/qBreakpad"
+ "git+https://github.com/getsentry/crashpad"
"git+https://github.com/mohabouje/WinToast"
"git+https://github.com/pajlada/settings"
"git+https://github.com/pajlada/signals"
@@ -53,7 +53,7 @@ prepare () {
cd "$srcdir/$_pkgname"
git submodule init
git config submodule.libcommuni $srcdir/$_pkgname/lib/libcommuni
- git config submodule.qBreakpad $srcdir/$_pkgname/lib/qBreakpad
+ git config submodule.lib/crashpad.url "$srcdir/crashpad"
git config submodule.WinToast $srcdir/$_pkgname/lib/WinToast
git config submodule.settings $srcdir/$_pkgname/lib/settings
git config submodule.signals $srcdir/$_pkgname/lib/signals
@@ -64,7 +64,7 @@ prepare () {
git config submodule.miniaudio $srcdir/$_pkgname/lib/miniaudio
git config submodule.magicenum $srcdir/$_pkgname/lib/magic_enum
git config submodule.googletest $srcdir/$_pkgname/lib/googletest
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build() {