summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Korn2015-06-09 20:46:37 +0200
committerChristoph Korn2015-06-09 20:46:37 +0200
commit159a0a2a638a5521dac33a301c8bcc721c3ca3d2 (patch)
tree2e6982dc4f9d131af5bdfa479f79ad24e2c39e81
downloadaur-159a0a2a638a5521dac33a301c8bcc721c3ca3d2.tar.gz
Initial import
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD58
-rw-r--r--build.patch35
-rw-r--r--chatty.desktop9
-rw-r--r--chatty.pngbin0 -> 3770 bytes
-rw-r--r--chatty_script3
-rw-r--r--client_id.patch14
-rw-r--r--config_dir.patch16
-rw-r--r--disable_version_check.patch60
-rw-r--r--manifest.patch8
10 files changed, 238 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9ea4d34d789
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by makepkg 4.2.1
+# Tue Jun 9 18:37:43 UTC 2015
+pkgbase = chatty
+ pkgdesc = Twitch Chat Client for Desktop
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://getchatty.sourceforge.net
+ arch = any
+ license = MIT
+ makedepends = apache-ant
+ makedepends = jre7-openjdk
+ depends = java-environment
+ depends = sh
+ optdepends = livestreamer: for watching streams in a custom video player.
+ source = http://downloads.sourceforge.net/getchatty/Chatty_0.8_source.zip
+ source = chatty.png
+ source = chatty.desktop
+ source = chatty_script
+ source = config_dir.patch
+ source = client_id.patch
+ source = manifest.patch
+ source = disable_version_check.patch
+ source = build.patch
+ md5sums = 05f1ea3a948719a89127f7feb9c0aa42
+ md5sums = 2bdf69cd81d941dba97d55694f9da26d
+ md5sums = 9d8950b786e1af5614bc705ad478b019
+ md5sums = 8f74b121a39705a33687ddf26dfdd2ac
+ md5sums = 6464228eceee06c4f8987df9b44bab65
+ md5sums = 2dd48d545926d8e9d5ab56df46dc09d3
+ md5sums = c6360077b684607a765f50a23006bbff
+ md5sums = 806ddd5794c5441b07733be4229bf9d2
+ md5sums = 79752de0a1a4dcc15067d9c33214ca3f
+
+pkgname = chatty
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..088eb9d46ee4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Christoph Korn <c_korn at gmx dot de>
+pkgname=chatty
+pkgver=0.8
+pkgrel=1
+pkgdesc="Twitch Chat Client for Desktop"
+arch=('any')
+url="http://getchatty.sourceforge.net"
+license=('MIT')
+depends=('java-environment' 'sh')
+optdepends=('livestreamer: for watching streams in a custom video player.')
+makedepends=('apache-ant' 'jre7-openjdk')
+
+source=("http://downloads.sourceforge.net/getchatty/Chatty_${pkgver}_source.zip"
+ "${pkgname}.png"
+ "${pkgname}.desktop"
+ "${pkgname}_script"
+ "config_dir.patch"
+ "client_id.patch"
+ "manifest.patch"
+ "disable_version_check.patch"
+ "build.patch")
+md5sums=('05f1ea3a948719a89127f7feb9c0aa42'
+ '2bdf69cd81d941dba97d55694f9da26d'
+ '9d8950b786e1af5614bc705ad478b019'
+ '8f74b121a39705a33687ddf26dfdd2ac'
+ '6464228eceee06c4f8987df9b44bab65'
+ '2dd48d545926d8e9d5ab56df46dc09d3'
+ 'c6360077b684607a765f50a23006bbff'
+ '806ddd5794c5441b07733be4229bf9d2'
+ '79752de0a1a4dcc15067d9c33214ca3f')
+
+prepare() {
+ patch -p1 -i $srcdir/build.patch
+ patch -p1 -i $srcdir/client_id.patch
+ patch -p1 -i $srcdir/config_dir.patch
+ patch -p1 -i $srcdir/disable_version_check.patch
+ patch -p1 -i $srcdir/manifest.patch
+}
+
+build() {
+ ant
+}
+
+package(){
+ install -Dm644 "${srcdir}/dist/${pkgname}.jar" "${pkgdir}/usr/share/${pkgname}/${pkgname}.jar"
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ cp -a "${srcdir}/sounds" "${pkgdir}/usr/share/${pkgname}/"
+
+ install -Dm755 "${srcdir}/${pkgname}_script" "${pkgdir}/usr/bin/${pkgname}"
+
+ install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm755 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ install -Dm644 "${srcdir}/APACHE_LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/APACHE_LICENSE"
+ install -Dm644 "${srcdir}/LGPL" "${pkgdir}/usr/share/licenses/${pkgname}/LGPL"
+ install -Dm644 "${srcdir}/README" "${pkgdir}/usr/share/licenses/${pkgname}/MIT"
+}
+
diff --git a/build.patch b/build.patch
new file mode 100644
index 000000000000..abe2ab932c55
--- /dev/null
+++ b/build.patch
@@ -0,0 +1,35 @@
+# make an own build.xml because the sources do not contain all build files
+Index: chatty-0.7.1/build.xml
+===================================================================
+--- /dev/null
++++ chatty-0.7.1/build.xml
+@@ -0,0 +1,29 @@
++<project name="chatty" default="jar">
++ <target name="clean">
++ <delete dir="bin"/>
++ <delete dir="dist"/>
++ <delete dir="lib/dlls"/>
++ </target>
++
++ <target name="compile" depends="clean">
++ <mkdir dir="bin"/>
++ <javac srcdir="src/chatty" encoding="utf-8" destdir="bin">
++ <classpath>
++ <fileset dir="lib">
++ <include name="**/*.jar" />
++ </fileset>
++ </classpath>
++ </javac>
++ <copy todir="bin">
++ <fileset dir="src" excludes="**/*.java"/>
++ </copy>
++ </target>
++
++ <target name="jar" depends="compile">
++ <mkdir dir="dist"/>
++ <jar manifest="manifest.mf" destfile="dist/chatty.jar">
++ <fileset dir="bin" />
++ <zipgroupfileset dir="lib" />
++ </jar>
++ </target>
++</project>
diff --git a/chatty.desktop b/chatty.desktop
new file mode 100644
index 000000000000..53d5c3f6bc57
--- /dev/null
+++ b/chatty.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=Chatty
+Exec=/usr/bin/chatty
+Icon=chatty
+Terminal=false
+Type=Application
+Categories=Application;Network;
+Keywords=twitch;chat;
diff --git a/chatty.png b/chatty.png
new file mode 100644
index 000000000000..91b8bb43740d
--- /dev/null
+++ b/chatty.png
Binary files differ
diff --git a/chatty_script b/chatty_script
new file mode 100644
index 000000000000..0e95afca4ce3
--- /dev/null
+++ b/chatty_script
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/chatty
+java -jar chatty.jar "$@"
diff --git a/client_id.patch b/client_id.patch
new file mode 100644
index 000000000000..ea78d78376a1
--- /dev/null
+++ b/client_id.patch
@@ -0,0 +1,14 @@
+# set client ID. Generated own ID from twitch
+Index: chatty-0.7.1/src/chatty/Chatty.java
+===================================================================
+--- chatty-0.7.1.orig/src/chatty/Chatty.java
++++ chatty-0.7.1/src/chatty/Chatty.java
+@@ -37,7 +37,7 @@ public class Chatty {
+ * If you compile this program yourself, you should create your own client
+ * id on http://www.twitch.tv/kraken/oauth2/clients/new
+ */
+- public static final String CLIENT_ID = <...>;
++ public static final String CLIENT_ID = "q1b6bqsamkie9jl3917hsvaq388psra";
+
+ /**
+ * The redirect URI for getting a token.
diff --git a/config_dir.patch b/config_dir.patch
new file mode 100644
index 000000000000..269bb11e633c
--- /dev/null
+++ b/config_dir.patch
@@ -0,0 +1,16 @@
+# change config directory to $HOME/.config/chatty
+Index: chatty-0.7.1/src/chatty/Chatty.java
+===================================================================
+--- chatty-0.7.1.orig/src/chatty/Chatty.java
++++ chatty-0.7.1/src/chatty/Chatty.java
+@@ -140,7 +140,9 @@ public class Chatty {
+ }
+ String dir = System.getProperty("user.home")
+ + File.separator
+- + ".chatty"
++ + ".config"
++ + File.separator
++ + "chatty"
+ + File.separator;
+ new File(dir).mkdirs();
+ return dir;
diff --git a/disable_version_check.patch b/disable_version_check.patch
new file mode 100644
index 000000000000..1a7e032acce3
--- /dev/null
+++ b/disable_version_check.patch
@@ -0,0 +1,60 @@
+# disable version check. updates come via package management
+Index: chatty-0.7.3/src/chatty/Version.java
+===================================================================
+--- chatty-0.7.3.orig/src/chatty/Version.java 2015-01-19 21:39:08.293772537 +0100
++++ chatty-0.7.3/src/chatty/Version.java 2015-01-19 21:39:08.285772538 +0100
+@@ -32,8 +32,8 @@
+ }
+
+ private void checkForNewVersion() {
+- LOGGER.info("Checking for new version..");
+- new Thread(new VersionChecker()).start();
++ //LOGGER.info("Checking for new version..");
++ //new Thread(new VersionChecker()).start();
+ }
+
+ /**
+Index: chatty-0.7.3/src/chatty/TwitchClient.java
+===================================================================
+--- chatty-0.7.3.orig/src/chatty/TwitchClient.java 2015-01-19 21:39:08.293772537 +0100
++++ chatty-0.7.3/src/chatty/TwitchClient.java 2015-01-19 21:39:08.289772538 +0100
+@@ -282,7 +282,7 @@
+
+ // Check version, if enabled in this build
+ if (Chatty.VERSION_CHECK_ENABLED) {
+- checkNewVersion();
++ //checkNewVersion();
+ }
+
+ // Connect or open connect dialog
+@@ -341,7 +341,7 @@
+ */
+ private void checkNewVersion() {
+ //g.setUpdateAvailable();
+- if (!settings.getBoolean("checkNewVersion")) {
++ /*if (!settings.getBoolean("checkNewVersion")) {
+ return;
+ }
+ long ago = System.currentTimeMillis() - settings.getLong("versionLastChecked");
+@@ -367,7 +367,7 @@
+ g.printSystem("You already have the newest version.");
+ }
+ }
+- });
++ });*/
+ }
+
+ /**
+Index: chatty-0.7.3/src/chatty/Chatty.java
+===================================================================
+--- chatty-0.7.3.orig/src/chatty/Chatty.java 2015-01-19 21:39:08.293772537 +0100
++++ chatty-0.7.3/src/chatty/Chatty.java 2015-01-19 21:39:08.289772538 +0100
+@@ -53,7 +53,7 @@
+ * Enable Version Checker (if you compile and distribute this yourself, you
+ * may want to disable this)
+ */
+- public static final boolean VERSION_CHECK_ENABLED = true;
++ public static final boolean VERSION_CHECK_ENABLED = false;
+
+ /**
+ * The regular URL of the textfile where the most recent version is stored.
diff --git a/manifest.patch b/manifest.patch
new file mode 100644
index 000000000000..e4eee2a61107
--- /dev/null
+++ b/manifest.patch
@@ -0,0 +1,8 @@
+# make a proper manifest
+Index: chatty-0.6/manifest.mf
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ chatty-0.6/manifest.mf 2014-02-14 17:49:57.795727061 +0100
+@@ -0,0 +1,2 @@
++Manifest-Version: 1.0
++Main-Class: chatty.Chatty