summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Korn2016-10-24 22:33:10 +0200
committerChristoph Korn2016-10-24 22:33:10 +0200
commit754a9d514d9c11904a683eee1cc90bc476eda402 (patch)
tree657a911b6da4780f74f9c4d1f52e9a3b89a381a4
parent9c54b7d929e2827c57862df2d5f8a43b17a4f8d4 (diff)
downloadaur-754a9d514d9c11904a683eee1cc90bc476eda402.tar.gz
0.8.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
-rw-r--r--build.patch90
-rw-r--r--manifest.patch14
4 files changed, 22 insertions, 106 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5d4b92ae661..c24a51e62b22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jul 5 18:57:33 UTC 2016
+# Mon Oct 24 20:30:39 UTC 2016
pkgbase = chatty
pkgdesc = Twitch Chat Client for Desktop
- pkgver = 0.8.3
- pkgrel = 3
+ pkgver = 0.8.4
+ pkgrel = 1
url = http://chatty.github.io/
arch = any
license = MIT
@@ -12,7 +12,7 @@ pkgbase = chatty
depends = java-environment
depends = sh
optdepends = livestreamer: for watching streams in a custom video player.
- source = https://github.com/chatty/chatty/archive/v0.8.3.tar.gz
+ source = https://github.com/chatty/chatty/archive/v0.8.4.tar.gz
source = chatty.png
source = chatty.desktop
source = chatty_script
@@ -20,14 +20,14 @@ pkgbase = chatty
source = manifest.patch
source = disable_version_check.patch
source = build.patch
- md5sums = 48afdbdfb9d9a2e3162f3e18a1aafd84
+ md5sums = e7d92638b6da7c5fdec288f982b31c7e
md5sums = 2bdf69cd81d941dba97d55694f9da26d
md5sums = 9d8950b786e1af5614bc705ad478b019
md5sums = e79577c8044fbee51426aaeb7613501f
md5sums = b94cff3408dc359815283663610ab866
- md5sums = 4de1c8a5b0fb16932b6106d8bdd193f7
+ md5sums = 6279e2e121741453561409ffed33a98d
md5sums = 4e3d8490acd2f8ba700d03809a8ca8cf
- md5sums = 096e2ad8590ff0b8e6a57869c8e79c3c
+ md5sums = c6416522e0585c7ad3b3ff476dd4d0e8
pkgname = chatty
diff --git a/PKGBUILD b/PKGBUILD
index ab86ef999524..8b8f34bcb826 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christoph Korn <christoph.korn at posteo dot de>
pkgname=chatty
-pkgver=0.8.3
-pkgrel=3
+pkgver=0.8.4
+pkgrel=1
pkgdesc="Twitch Chat Client for Desktop"
arch=('any')
url="http://chatty.github.io/"
@@ -18,14 +18,14 @@ source=("https://github.com/chatty/chatty/archive/v${pkgver}.tar.gz"
"manifest.patch"
"disable_version_check.patch"
"build.patch")
-md5sums=('48afdbdfb9d9a2e3162f3e18a1aafd84'
+md5sums=('e7d92638b6da7c5fdec288f982b31c7e'
'2bdf69cd81d941dba97d55694f9da26d'
'9d8950b786e1af5614bc705ad478b019'
'e79577c8044fbee51426aaeb7613501f'
'b94cff3408dc359815283663610ab866'
- '4de1c8a5b0fb16932b6106d8bdd193f7'
+ '6279e2e121741453561409ffed33a98d'
'4e3d8490acd2f8ba700d03809a8ca8cf'
- '096e2ad8590ff0b8e6a57869c8e79c3c')
+ 'c6416522e0585c7ad3b3ff476dd4d0e8')
prepare() {
cd chatty-${pkgver}
diff --git a/build.patch b/build.patch
index c5b2019d2270..21dba0f874f2 100644
--- a/build.patch
+++ b/build.patch
@@ -1,87 +1,7 @@
-# make an own build.xml because the sources do not contain all build files
-Index: chatty-0.8.2/build.xml
-===================================================================
---- chatty-0.8.2.orig/build.xml 2016-04-26 22:53:02.932618803 +0200
-+++ chatty-0.8.2/build.xml 2016-04-26 22:53:39.409388013 +0200
-@@ -1,79 +1,29 @@
--<?xml version="1.0" encoding="UTF-8"?>
--<!-- You may freely edit this file. See commented blocks below for -->
--<!-- some examples of how to customize the build. -->
--<!-- (If you delete it and reopen the project it will be recreated.) -->
--<!-- By default, only the Clean and Build commands use this build script. -->
--<!-- Commands such as Run, Debug, and Test only use this build script if -->
--<!-- the Compile on Save feature is turned off for the project. -->
--<!-- You can turn off the Compile on Save (or Deploy on Save) setting -->
--<!-- in the project's Project Properties dialog box.-->
--<project name="Chatty" default="default" basedir=".">
-- <description>Builds, tests, and runs the project Chatty.</description>
-- <import file="nbproject/build-impl.xml"/>
-- <!--
--
-- There exist several targets which are by default empty and which can be
-- used for execution of your tasks. These targets are usually executed
-- before and after some main targets. They are:
--
-- -pre-init: called before initialization of project properties
-- -post-init: called after initialization of project properties
-- -pre-compile: called before javac compilation
-- -post-compile: called after javac compilation
-- -pre-compile-single: called before javac compilation of single file
-- -post-compile-single: called after javac compilation of single file
-- -pre-compile-test: called before javac compilation of JUnit tests
-- -post-compile-test: called after javac compilation of JUnit tests
-- -pre-compile-test-single: called before javac compilation of single JUnit test
-- -post-compile-test-single: called after javac compilation of single JUunit test
-- -pre-jar: called before JAR building
-- -post-jar: called after JAR building
-- -post-clean: called after cleaning build products
--
-- (Targets beginning with '-' are not intended to be called on their own.)
--
-- Example of inserting an obfuscator after compilation could look like this:
--
-- <target name="-post-compile">
-- <obfuscate>
-- <fileset dir="${build.classes.dir}"/>
-- </obfuscate>
-- </target>
--
-- For list of available properties check the imported
-- nbproject/build-impl.xml file.
--
--
-- Another way to customize the build is by overriding existing main targets.
-- The targets of interest are:
--
-- -init-macrodef-javac: defines macro for javac compilation
-- -init-macrodef-junit: defines macro for junit execution
-- -init-macrodef-debug: defines macro for class debugging
-- -init-macrodef-java: defines macro for class execution
-- -do-jar-with-manifest: JAR building (if you are using a manifest)
-- -do-jar-without-manifest: JAR building (if you are not using a manifest)
-- run: execution of project
-- -javadoc-build: Javadoc generation
-- test-report: JUnit report generation
--
-- An example of overriding the target for project execution could look like this:
--
-- <target name="run" depends="Chatty-impl.jar">
-- <exec dir="bin" executable="launcher.exe">
-- <arg file="${dist.jar}"/>
-- </exec>
-- </target>
--
-- Notice that the overridden target depends on the jar target and not only on
-- the compile target as the regular run target does. Again, for a list of available
-- properties which you can use, check the target you are overriding in the
-- nbproject/build-impl.xml file.
--
-- -->
-- <target name="-post-jar">
-- <copy todir="${dist.dir}/sounds/">
-- <fileset dir="assets/sounds" />
-- </copy>
-- </target>
+diff -Nur chatty-0.8.4.orig/build.xml chatty-0.8.4/build.xml
+--- chatty-0.8.4.orig/build.xml 1970-01-01 01:00:00.000000000 +0100
++++ chatty-0.8.4/build.xml 2016-10-24 22:23:20.312077302 +0200
+@@ -0,0 +1,29 @@
+<project name="chatty" default="jar">
+ <target name="clean">
+ <delete dir="bin"/>
@@ -110,4 +30,4 @@ Index: chatty-0.8.2/build.xml
+ <zipgroupfileset dir="assets/lib" />
+ </jar>
+ </target>
- </project>
++ </project>
diff --git a/manifest.patch b/manifest.patch
index dd22588ecac7..e68f68782e8c 100644
--- a/manifest.patch
+++ b/manifest.patch
@@ -1,10 +1,6 @@
-# make a proper manifest
-Index: chatty-0.8.2/manifest.mf
-===================================================================
---- chatty-0.8.2.orig/manifest.mf 2016-04-26 22:45:58.827753038 +0200
-+++ chatty-0.8.2/manifest.mf 2016-04-26 22:46:24.096275971 +0200
-@@ -1,3 +1,3 @@
- Manifest-Version: 1.0
--X-COMMENT: Main-Class will be added automatically by build
+diff -Nur chatty-0.8.4.orig/manifest.mf chatty-0.8.4/manifest.mf
+--- chatty-0.8.4.orig/manifest.mf 1970-01-01 01:00:00.000000000 +0100
++++ chatty-0.8.4/manifest.mf 2016-10-24 22:20:19.004420770 +0200
+@@ -0,0 +1,2 @@
++Manifest-Version: 1.0
+Main-Class: chatty.Chatty
-