summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Korn2016-04-27 00:41:56 +0200
committerChristoph Korn2016-04-27 00:41:56 +0200
commite0d63f593e0ff95bab016e69c6996f1f2fb01037 (patch)
tree969ec8dcd3a9de8f40c68a0d0c26ba49f1ad0dcd
parent9c4b49d9a61964a0c7a03723e838bf18d2ff2ac5 (diff)
downloadaur-e0d63f593e0ff95bab016e69c6996f1f2fb01037.tar.gz
0.8.2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD14
-rw-r--r--build.patch170
-rw-r--r--config_dir.patch34
-rw-r--r--disable_version_check.patch175
-rw-r--r--manifest.patch20
6 files changed, 213 insertions, 218 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffc30397a123..f407aa077d32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Feb 15 19:59:41 UTC 2016
+# Tue Apr 26 22:37:27 UTC 2016
pkgbase = chatty
pkgdesc = Twitch Chat Client for Desktop
- pkgver = 0.8.1
- pkgrel = 3
+ pkgver = 0.8.2
+ pkgrel = 1
url = http://chatty.github.io/
arch = any
license = MIT
@@ -12,7 +12,7 @@ pkgbase = chatty
depends = java-environment
depends = sh
optdepends = livestreamer: for watching streams in a custom video player.
- source = https://github.com/chatty/chatty/archive/v0.8.1.tar.gz
+ source = https://github.com/chatty/chatty/archive/v0.8.2.tar.gz
source = chatty.png
source = chatty.desktop
source = chatty_script
@@ -20,14 +20,14 @@ pkgbase = chatty
source = manifest.patch
source = disable_version_check.patch
source = build.patch
- md5sums = ec686a2146c166bf50ee330a9c590f82
+ md5sums = 1172b5f7d788a7258fbbec07f6ca7dcc
md5sums = 2bdf69cd81d941dba97d55694f9da26d
md5sums = 9d8950b786e1af5614bc705ad478b019
md5sums = 8f74b121a39705a33687ddf26dfdd2ac
- md5sums = 6464228eceee06c4f8987df9b44bab65
- md5sums = 1432edb5b8a728106bd7e76e042c8e9f
- md5sums = 6c62ed9c73b42b9a629d796b3358c193
- md5sums = ff584c4f1ce48e0ae48a4fc131999be2
+ md5sums = b94cff3408dc359815283663610ab866
+ md5sums = 4de1c8a5b0fb16932b6106d8bdd193f7
+ md5sums = 4e3d8490acd2f8ba700d03809a8ca8cf
+ md5sums = 096e2ad8590ff0b8e6a57869c8e79c3c
pkgname = chatty
diff --git a/PKGBUILD b/PKGBUILD
index f047237acc1b..3d72be0cc89f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christoph Korn <christoph.korn at posteo dot de>
pkgname=chatty
-pkgver=0.8.1
-pkgrel=3
+pkgver=0.8.2
+pkgrel=1
pkgdesc="Twitch Chat Client for Desktop"
arch=('any')
url="http://chatty.github.io/"
@@ -18,14 +18,14 @@ source=("https://github.com/chatty/chatty/archive/v${pkgver}.tar.gz"
"manifest.patch"
"disable_version_check.patch"
"build.patch")
-md5sums=('ec686a2146c166bf50ee330a9c590f82'
+md5sums=('1172b5f7d788a7258fbbec07f6ca7dcc'
'2bdf69cd81d941dba97d55694f9da26d'
'9d8950b786e1af5614bc705ad478b019'
'8f74b121a39705a33687ddf26dfdd2ac'
- '6464228eceee06c4f8987df9b44bab65'
- '1432edb5b8a728106bd7e76e042c8e9f'
- '6c62ed9c73b42b9a629d796b3358c193'
- 'ff584c4f1ce48e0ae48a4fc131999be2')
+ 'b94cff3408dc359815283663610ab866'
+ '4de1c8a5b0fb16932b6106d8bdd193f7'
+ '4e3d8490acd2f8ba700d03809a8ca8cf'
+ '096e2ad8590ff0b8e6a57869c8e79c3c')
prepare() {
cd chatty-${pkgver}
diff --git a/build.patch b/build.patch
index 4512af21a327..c5b2019d2270 100644
--- a/build.patch
+++ b/build.patch
@@ -1,88 +1,87 @@
# make an own build.xml because the sources do not contain all build files
-diff --git a/build.xml b/build.xml
-index aa14e9f..c752517 100644
---- a/build.xml
-+++ b/build.xml
+Index: chatty-0.8.2/build.xml
+===================================================================
+--- chatty-0.8.2.orig/build.xml 2016-04-26 22:53:02.932618803 +0200
++++ chatty-0.8.2/build.xml 2016-04-26 22:53:39.409388013 +0200
@@ -1,79 +1,29 @@
--<?xml version="1.0" encoding="UTF-8"?>
--<!-- You may freely edit this file. See commented blocks below for -->
--<!-- some examples of how to customize the build. -->
--<!-- (If you delete it and reopen the project it will be recreated.) -->
--<!-- By default, only the Clean and Build commands use this build script. -->
--<!-- Commands such as Run, Debug, and Test only use this build script if -->
--<!-- the Compile on Save feature is turned off for the project. -->
--<!-- You can turn off the Compile on Save (or Deploy on Save) setting -->
--<!-- in the project's Project Properties dialog box.-->
--<project name="Chatty" default="default" basedir=".">
-- <description>Builds, tests, and runs the project Chatty.</description>
-- <import file="nbproject/build-impl.xml"/>
-- <!--
--
-- There exist several targets which are by default empty and which can be
-- used for execution of your tasks. These targets are usually executed
-- before and after some main targets. They are:
--
-- -pre-init: called before initialization of project properties
-- -post-init: called after initialization of project properties
-- -pre-compile: called before javac compilation
-- -post-compile: called after javac compilation
-- -pre-compile-single: called before javac compilation of single file
-- -post-compile-single: called after javac compilation of single file
-- -pre-compile-test: called before javac compilation of JUnit tests
-- -post-compile-test: called after javac compilation of JUnit tests
-- -pre-compile-test-single: called before javac compilation of single JUnit test
-- -post-compile-test-single: called after javac compilation of single JUunit test
-- -pre-jar: called before JAR building
-- -post-jar: called after JAR building
-- -post-clean: called after cleaning build products
--
-- (Targets beginning with '-' are not intended to be called on their own.)
--
-- Example of inserting an obfuscator after compilation could look like this:
--
-- <target name="-post-compile">
-- <obfuscate>
-- <fileset dir="${build.classes.dir}"/>
-- </obfuscate>
-- </target>
--
-- For list of available properties check the imported
-- nbproject/build-impl.xml file.
--
--
-- Another way to customize the build is by overriding existing main targets.
-- The targets of interest are:
--
-- -init-macrodef-javac: defines macro for javac compilation
-- -init-macrodef-junit: defines macro for junit execution
-- -init-macrodef-debug: defines macro for class debugging
-- -init-macrodef-java: defines macro for class execution
-- -do-jar-with-manifest: JAR building (if you are using a manifest)
-- -do-jar-without-manifest: JAR building (if you are not using a manifest)
-- run: execution of project
-- -javadoc-build: Javadoc generation
-- test-report: JUnit report generation
--
-- An example of overriding the target for project execution could look like this:
--
-- <target name="run" depends="Chatty-impl.jar">
-- <exec dir="bin" executable="launcher.exe">
-- <arg file="${dist.jar}"/>
-- </exec>
-- </target>
--
-- Notice that the overridden target depends on the jar target and not only on
-- the compile target as the regular run target does. Again, for a list of available
-- properties which you can use, check the target you are overriding in the
-- nbproject/build-impl.xml file.
--
-- -->
-- <target name="-post-jar">
-- <copy todir="${dist.dir}/sounds/">
-- <fileset dir="assets/sounds" />
-- </copy>
-- </target>
--</project>
+-<?xml version="1.0" encoding="UTF-8"?>
+-<!-- You may freely edit this file. See commented blocks below for -->
+-<!-- some examples of how to customize the build. -->
+-<!-- (If you delete it and reopen the project it will be recreated.) -->
+-<!-- By default, only the Clean and Build commands use this build script. -->
+-<!-- Commands such as Run, Debug, and Test only use this build script if -->
+-<!-- the Compile on Save feature is turned off for the project. -->
+-<!-- You can turn off the Compile on Save (or Deploy on Save) setting -->
+-<!-- in the project's Project Properties dialog box.-->
+-<project name="Chatty" default="default" basedir=".">
+- <description>Builds, tests, and runs the project Chatty.</description>
+- <import file="nbproject/build-impl.xml"/>
+- <!--
+-
+- There exist several targets which are by default empty and which can be
+- used for execution of your tasks. These targets are usually executed
+- before and after some main targets. They are:
+-
+- -pre-init: called before initialization of project properties
+- -post-init: called after initialization of project properties
+- -pre-compile: called before javac compilation
+- -post-compile: called after javac compilation
+- -pre-compile-single: called before javac compilation of single file
+- -post-compile-single: called after javac compilation of single file
+- -pre-compile-test: called before javac compilation of JUnit tests
+- -post-compile-test: called after javac compilation of JUnit tests
+- -pre-compile-test-single: called before javac compilation of single JUnit test
+- -post-compile-test-single: called after javac compilation of single JUunit test
+- -pre-jar: called before JAR building
+- -post-jar: called after JAR building
+- -post-clean: called after cleaning build products
+-
+- (Targets beginning with '-' are not intended to be called on their own.)
+-
+- Example of inserting an obfuscator after compilation could look like this:
+-
+- <target name="-post-compile">
+- <obfuscate>
+- <fileset dir="${build.classes.dir}"/>
+- </obfuscate>
+- </target>
+-
+- For list of available properties check the imported
+- nbproject/build-impl.xml file.
+-
+-
+- Another way to customize the build is by overriding existing main targets.
+- The targets of interest are:
+-
+- -init-macrodef-javac: defines macro for javac compilation
+- -init-macrodef-junit: defines macro for junit execution
+- -init-macrodef-debug: defines macro for class debugging
+- -init-macrodef-java: defines macro for class execution
+- -do-jar-with-manifest: JAR building (if you are using a manifest)
+- -do-jar-without-manifest: JAR building (if you are not using a manifest)
+- run: execution of project
+- -javadoc-build: Javadoc generation
+- test-report: JUnit report generation
+-
+- An example of overriding the target for project execution could look like this:
+-
+- <target name="run" depends="Chatty-impl.jar">
+- <exec dir="bin" executable="launcher.exe">
+- <arg file="${dist.jar}"/>
+- </exec>
+- </target>
+-
+- Notice that the overridden target depends on the jar target and not only on
+- the compile target as the regular run target does. Again, for a list of available
+- properties which you can use, check the target you are overriding in the
+- nbproject/build-impl.xml file.
+-
+- -->
+- <target name="-post-jar">
+- <copy todir="${dist.dir}/sounds/">
+- <fileset dir="assets/sounds" />
+- </copy>
+- </target>
+<project name="chatty" default="jar">
+ <target name="clean">
+ <delete dir="bin"/>
@@ -111,7 +110,4 @@ index aa14e9f..c752517 100644
+ <zipgroupfileset dir="assets/lib" />
+ </jar>
+ </target>
-+</project>
---
-2.5.0
-
+ </project>
diff --git a/config_dir.patch b/config_dir.patch
index 269bb11e633c..6a29db3e269a 100644
--- a/config_dir.patch
+++ b/config_dir.patch
@@ -1,16 +1,22 @@
# change config directory to $HOME/.config/chatty
-Index: chatty-0.7.1/src/chatty/Chatty.java
+Index: chatty-0.8.2/src/chatty/Chatty.java
===================================================================
---- chatty-0.7.1.orig/src/chatty/Chatty.java
-+++ chatty-0.7.1/src/chatty/Chatty.java
-@@ -140,7 +140,9 @@ public class Chatty {
- }
- String dir = System.getProperty("user.home")
- + File.separator
-- + ".chatty"
-+ + ".config"
-+ + File.separator
-+ + "chatty"
- + File.separator;
- new File(dir).mkdirs();
- return dir;
+--- chatty-0.8.2.orig/src/chatty/Chatty.java 2016-04-26 22:43:29.316678569 +0200
++++ chatty-0.8.2/src/chatty/Chatty.java 2016-04-26 22:44:05.245414029 +0200
+@@ -186,12 +186,11 @@
+ * @return
+ */
+ public static String getUserDataDirectory() {
+- if (useCurrentDirectory) {
+- return System.getProperty("user.dir") + File.separator;
+- }
+ String dir = System.getProperty("user.home")
+- + File.separator
+- + ".chatty"
++ + File.separator
++ + ".config"
++ + File.separator
++ + "chatty"
+ + File.separator;
+ new File(dir).mkdirs();
+ return dir;
diff --git a/disable_version_check.patch b/disable_version_check.patch
index 968b7a6652fc..6eb142c5e585 100644
--- a/disable_version_check.patch
+++ b/disable_version_check.patch
@@ -1,90 +1,87 @@
# disable version check. updates come via package management
-diff --git a/src/chatty/Chatty.java b/src/chatty/Chatty.java
-index 2fdc077..5c39dd8 100644
---- a/src/chatty/Chatty.java
-+++ b/src/chatty/Chatty.java
-@@ -53,7 +53,7 @@ public class Chatty {
- * Enable Version Checker (if you compile and distribute this yourself, you
- * may want to disable this)
- */
-- public static final boolean VERSION_CHECK_ENABLED = true;
-+ public static final boolean VERSION_CHECK_ENABLED = false;
-
- /**
- * The regular URL of the textfile where the most recent version is stored.
-diff --git a/src/chatty/TwitchClient.java b/src/chatty/TwitchClient.java
-index 8bea1db..b900837 100644
---- a/src/chatty/TwitchClient.java
-+++ b/src/chatty/TwitchClient.java
-@@ -262,7 +262,7 @@ public class TwitchClient {
- checkForVersionChange();
- // Check version, if enabled in this build
- if (Chatty.VERSION_CHECK_ENABLED) {
-- checkNewVersion();
-+ //checkNewVersion();
- }
-
- // Connect or open connect dialog
-@@ -370,44 +370,7 @@ public class TwitchClient {
- * Checks for a new version if the last check was long enough ago.
- */
- private void checkNewVersion() {
-- if (!settings.getBoolean("checkNewVersion")) {
-- return;
-- }
-- /**
-- * Check if enough time has passed since the last check.
-- */
-- long ago = System.currentTimeMillis() - settings.getLong("versionLastChecked");
-- if (ago/1000 < CHECK_VERSION_INTERVAL) {
-- /**
-- * If not checking, check if update was detected last time.
-- */
-- String updateAvailable = settings.getString("updateAvailable");
-- if (!updateAvailable.isEmpty()) {
-- g.setUpdateAvailable(updateAvailable);
-- }
-- return;
-- }
-- settings.setLong("versionLastChecked", System.currentTimeMillis());
-- g.printSystem("Checking for new version..");
-
-- new Version(new VersionListener() {
--
-- @Override
-- public void versionChecked(String version, String info, boolean isNewVersion) {
-- if (isNewVersion) {
-- String infoText = "";
-- if (!info.isEmpty()) {
-- infoText = "[" + info + "] ";
-- }
-- g.printSystem("New version available: "+version+" "+infoText
-- +"(Go to <Help-Website> to download)");
-- g.setUpdateAvailable(version);
-- settings.setString("updateAvailable", version);
-- } else {
-- g.printSystem("You already have the newest version.");
-- }
-- }
-- });
- }
-
- /**
-diff --git a/src/chatty/Version.java b/src/chatty/Version.java
-index 2f6d9c4..6ac5227 100644
---- a/src/chatty/Version.java
-+++ b/src/chatty/Version.java
-@@ -32,8 +32,8 @@ public class Version {
- }
-
- private void checkForNewVersion() {
-- LOGGER.info("Checking for new version..");
-- new Thread(new VersionChecker()).start();
-+ //LOGGER.info("Checking for new version..");
-+ //new Thread(new VersionChecker()).start();
- }
-
- /**
---
-2.5.0
-
+Index: chatty-0.8.2/src/chatty/Chatty.java
+===================================================================
+--- chatty-0.8.2.orig/src/chatty/Chatty.java 2016-04-26 22:46:41.680640379 +0200
++++ chatty-0.8.2/src/chatty/Chatty.java 2016-04-26 22:50:03.208841787 +0200
+@@ -58,7 +58,7 @@
+ * Enable Version Checker (if you compile and distribute this yourself, you
+ * may want to disable this)
+ */
+- public static final boolean VERSION_CHECK_ENABLED = true;
++ public static final boolean VERSION_CHECK_ENABLED = false;
+
+ /**
+ * The regular URL of the textfile where the most recent version is stored.
+Index: chatty-0.8.2/src/chatty/TwitchClient.java
+===================================================================
+--- chatty-0.8.2.orig/src/chatty/TwitchClient.java 2016-04-26 22:47:26.953580371 +0200
++++ chatty-0.8.2/src/chatty/TwitchClient.java 2016-04-26 22:51:15.054348837 +0200
+@@ -298,7 +298,7 @@
+ checkForVersionChange();
+ // Check version, if enabled in this build
+ if (Chatty.VERSION_CHECK_ENABLED) {
+- checkNewVersion();
++ //checkNewVersion();
+ }
+
+ // Connect or open connect dialog
+@@ -368,44 +368,7 @@
+ * Checks for a new version if the last check was long enough ago.
+ */
+ private void checkNewVersion() {
+- if (!settings.getBoolean("checkNewVersion")) {
+- return;
+- }
+- /**
+- * Check if enough time has passed since the last check.
+- */
+- long ago = System.currentTimeMillis() - settings.getLong("versionLastChecked");
+- if (ago/1000 < CHECK_VERSION_INTERVAL) {
+- /**
+- * If not checking, check if update was detected last time.
+- */
+- String updateAvailable = settings.getString("updateAvailable");
+- if (!updateAvailable.isEmpty()) {
+- g.setUpdateAvailable(updateAvailable);
+- }
+- return;
+- }
+- settings.setLong("versionLastChecked", System.currentTimeMillis());
+- g.printSystem("Checking for new version..");
+-
+- new Version(new VersionListener() {
+
+- @Override
+- public void versionChecked(String version, String info, boolean isNewVersion) {
+- if (isNewVersion) {
+- String infoText = "";
+- if (!info.isEmpty()) {
+- infoText = "[" + info + "] ";
+- }
+- g.printSystem("New version available: "+version+" "+infoText
+- +"(Go to <Help-Website> to download)");
+- g.setUpdateAvailable(version);
+- settings.setString("updateAvailable", version);
+- } else {
+- g.printSystem("You already have the newest version.");
+- }
+- }
+- });
+ }
+
+ /**
+Index: chatty-0.8.2/src/chatty/Version.java
+===================================================================
+--- chatty-0.8.2.orig/src/chatty/Version.java 2016-04-26 22:47:26.953580371 +0200
++++ chatty-0.8.2/src/chatty/Version.java 2016-04-26 22:51:48.071042729 +0200
+@@ -32,8 +32,8 @@
+ }
+
+ private void checkForNewVersion() {
+- LOGGER.info("Checking for new version..");
+- new Thread(new VersionChecker()).start();
++ //LOGGER.info("Checking for new version..");
++ //new Thread(new VersionChecker()).start();
+ }
+
+ /**
diff --git a/manifest.patch b/manifest.patch
index c062fb40be7c..dd22588ecac7 100644
--- a/manifest.patch
+++ b/manifest.patch
@@ -1,14 +1,10 @@
# make a proper manifest
-diff --git a/manifest.mf b/manifest.mf
-index 1574df4..79d6981 100644
---- a/manifest.mf
-+++ b/manifest.mf
-@@ -1,3 +1,2 @@
--Manifest-Version: 1.0
--X-COMMENT: Main-Class will be added automatically by build
--
-+Manifest-Version: 1.0
+Index: chatty-0.8.2/manifest.mf
+===================================================================
+--- chatty-0.8.2.orig/manifest.mf 2016-04-26 22:45:58.827753038 +0200
++++ chatty-0.8.2/manifest.mf 2016-04-26 22:46:24.096275971 +0200
+@@ -1,3 +1,3 @@
+ Manifest-Version: 1.0
+-X-COMMENT: Main-Class will be added automatically by build
+Main-Class: chatty.Chatty
---
-2.5.0
-
+