summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfossdd2024-11-23 14:49:22 +0100
committerfossdd2024-11-23 14:51:07 +0100
commitb0272793a26f7879d201bff098770a6405df5fb7 (patch)
treee85311ff940078c8546a6428134d32701a6f1065
parent365de554844e6d24032be0bbed5438a68b36d257 (diff)
downloadaur-b0272793a26f7879d201bff098770a6405df5fb7.tar.gz
upgpkg: chatty-git r1.abeb9ed-1: switch to SMS application chatty
-rw-r--r--.SRCINFO54
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD106
-rw-r--r--chatty.desktop9
-rw-r--r--chatty_script3
-rw-r--r--disable_version_check.patch14
6 files changed, 89 insertions, 102 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c586894ad09b..dcf2434c30cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,38 @@
pkgbase = chatty-git
- pkgdesc = Twitch Chat Client for Desktop
- pkgver = 0.24.1.r0.ge17ed1d3
+ pkgdesc = Simple to use SMS and Matrix messaging application (development version)
+ pkgver = r1.abeb9ed
pkgrel = 1
- url = https://chatty.github.io/
- arch = any
- license = GPL3
- makedepends = gradle7
- depends = java-environment
- depends = sh
- optdepends = streamlink: for watching streams in a custom video player.
- optdepends = livestreamer: for watching streams in a custom video player.
- provides = chatty
- conflicts = chatty
- source = chatty-git::git+https://github.com/chatty/chatty
- source = chatty.desktop
- source = chatty_script
- source = disable_version_check.patch
- sha256sums = SKIP
- sha256sums = 336ec8a45dee69253a636f5f6f1159ab5fb2677e5c1927cc9272d43f7cb6488c
- sha256sums = 848069a724fcb691a0cd231dbb53e5900088fd5ed6eb6eac0ea0963eb8e689fb
- sha256sums = bcee0f6aae04498dcd26a68fe6ae09e924152f4fd3746b082adb1a0d241958df
+ url = https://gitlab.gnome.org/World/Chatty
+ arch = x86_64
+ arch = aarch64
+ arch = riscv64
+ license = GPL-3.0-or-later
+ checkdepends = xorg-server-xvfb
+ makedepends = appstream
+ makedepends = git
+ makedepends = itstool
+ makedepends = meson
+ depends = cairo
+ depends = dconf
+ depends = evolution-data-server
+ depends = feedbackd
+ depends = gcc-libs
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gnome-desktop-4
+ depends = gstreamer
+ depends = gtk4
+ depends = gtksourceview5
+ depends = hicolor-icon-theme
+ depends = libadwaita
+ depends = libcmatrix
+ depends = libmm-glib
+ depends = libphonenumber
+ depends = libspelling
+ depends = pango
+ depends = sqlite
+ source = git+https://gitlab.gnome.org/World/Chatty.git#branch=main
+ b2sums = SKIP
pkgname = chatty-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 84607370cd0d..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,5 +0,0 @@
-src
-pkg
-chatty-git
-*.pkg.tar.*
-tags
diff --git a/PKGBUILD b/PKGBUILD
index 9255219cc787..d4f4b467e2e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,67 @@
-# Maintainer: Tony Lambiris <tony@libpcap.net>
+# Maintainer: fossdd <fossdd@pwned.life>
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
pkgname=chatty-git
-_pkgname=${pkgname%-git}
-pkgver=0.24.1.r0.ge17ed1d3
+pkgver=r1.abeb9ed
pkgrel=1
-pkgdesc='Twitch Chat Client for Desktop'
-arch=('any')
-url='https://chatty.github.io/'
-license=('GPL3')
-depends=('java-environment' 'sh')
-optdepends=('streamlink: for watching streams in a custom video player.'
- 'livestreamer: for watching streams in a custom video player.')
-makedepends=('gradle7')
-provides=(${_pkgname})
-conflicts=(${_pkgname})
-source=("${pkgname}::git+https://github.com/chatty/chatty"
- "${_pkgname}.desktop"
- "${_pkgname}_script"
- "disable_version_check.patch")
-sha256sums=('SKIP'
- '336ec8a45dee69253a636f5f6f1159ab5fb2677e5c1927cc9272d43f7cb6488c'
- '848069a724fcb691a0cd231dbb53e5900088fd5ed6eb6eac0ea0963eb8e689fb'
- 'bcee0f6aae04498dcd26a68fe6ae09e924152f4fd3746b082adb1a0d241958df')
+pkgdesc='Simple to use SMS and Matrix messaging application (development version)'
+arch=(x86_64 aarch64 riscv64)
+url='https://gitlab.gnome.org/World/Chatty'
+license=(GPL-3.0-or-later)
+depends=(
+ cairo
+ dconf
+ evolution-data-server
+ feedbackd
+ gcc-libs
+ gdk-pixbuf2
+ glib2
+ glibc
+ gnome-desktop-4
+ gstreamer
+ gtk4
+ gtksourceview5
+ hicolor-icon-theme
+ libadwaita
+ libcmatrix
+ libmm-glib
+ libphonenumber
+ libspelling
+ pango
+ sqlite
+)
+makedepends=(
+ appstream
+ git
+ itstool
+ meson
+)
+checkdepends=(xorg-server-xvfb)
+source=(
+ "git+https://gitlab.gnome.org/World/Chatty.git#branch=main"
+)
+b2sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
-
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
-}
-
-prepare() {
- cd "${srcdir}/${pkgname}"
-
- patch -p1 -i '../disable_version_check.patch'
+ cd Chatty
+ ( set -o pipefail
+ git describe --long --abbrev=7 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ )
}
build() {
- cd "${srcdir}/${pkgname}"
-
- gradle7 --quiet build
- gradle7 --quiet release
+ arch-meson Chatty build \
+ -D purple=disabled
+ meson compile -C build
}
-package(){
- cd "${srcdir}/${pkgname}"
-
- mkdir -p "${srcdir}/Chatty_${pkgver}"
- pushd "${srcdir}/Chatty_${pkgver}"
- _zipfile="$(ls -t ${srcdir}/${pkgname}/build/releases/Chatty_*.zip | head -1)"
- bsdcpio -i -m --make-directories < "${_zipfile}"
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "readme.txt" "${pkgdir}/usr/share/doc/${pkgname}/readme.txt"
- install -Dm644 "Chatty.jar" "${pkgdir}/usr/share/${pkgname}/Chatty.jar"
- cp -a "img" "sounds" "${pkgdir}/usr/share/${pkgname}/"
- popd
+check() {
+ dbus-run-session xvfb-run \
+ -s '-screen 0 1920x1080x24 -nolisten local' \
+ meson test -C build --print-errorlogs
+}
- install -Dm755 "${srcdir}/${_pkgname}_script" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
- install -Dm644 "src/chatty/gui/app_main_16.png" "${pkgdir}/usr/share/icons/hicolor/16x16/apps/${_pkgname}.png"
- install -Dm644 "src/chatty/gui/app_main_64.png" "${pkgdir}/usr/share/icons/hicolor/64x64/apps/${_pkgname}.png"
- install -Dm644 "src/chatty/gui/app_main_128.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/${_pkgname}.png"
+package() {
+ meson install -C build --destdir "$pkgdir"
}
diff --git a/chatty.desktop b/chatty.desktop
deleted file mode 100644
index 53d5c3f6bc57..000000000000
--- a/chatty.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=Chatty
-Exec=/usr/bin/chatty
-Icon=chatty
-Terminal=false
-Type=Application
-Categories=Application;Network;
-Keywords=twitch;chat;
diff --git a/chatty_script b/chatty_script
deleted file mode 100644
index 3e51ad38f121..000000000000
--- a/chatty_script
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd /usr/share/chatty-git
-java -jar Chatty.jar "$@"
diff --git a/disable_version_check.patch b/disable_version_check.patch
deleted file mode 100644
index 86e5d3dae02a..000000000000
--- a/disable_version_check.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-# disable version check. updates come via package management
-Index: chatty-0.8.2/src/chatty/Chatty.java
-===================================================================
---- chatty-0.8.2.orig/src/chatty/Chatty.java 2016-04-26 22:46:41.680640379 +0200
-+++ chatty-0.8.2/src/chatty/Chatty.java 2016-04-26 22:50:03.208841787 +0200
-@@ -58,7 +58,7 @@
- * Enable Version Checker (if you compile and distribute this yourself, you
- * may want to disable this)
- */
-- public static final boolean VERSION_CHECK_ENABLED = true;
-+ public static final boolean VERSION_CHECK_ENABLED = false;
-
- /**
- * The regular URL of the textfile where the most recent version is stored.