summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2016-07-31 19:43:08 +0200
committerBalló György2016-07-31 19:43:08 +0200
commit0e23f8c726cc400692515d4836e6817e83607ffa (patch)
treebabf4ada1f047505f1a2551d3c8542c0ce918e45
downloadaur-0e23f8c726cc400692515d4836e6817e83607ffa.tar.gz
Add chatzilla
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
-rw-r--r--chatzilla.desktop10
-rwxr-xr-xchatzilla.sh1
-rw-r--r--version.patch12
5 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d8cb062fcde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = chatzilla
+ pkgdesc = Clean, easy to use and highly extensible Internet Relay Chat (IRC) client, built on the Mozilla platform
+ pkgver = 0.9.92
+ pkgrel = 1
+ url = http://chatzilla.hacksrus.com/
+ arch = any
+ license = MPL
+ license = GPL
+ license = LGPL
+ makedepends = python2
+ makedepends = unzip
+ depends = firefox
+ source = chatzilla-0.9.92.tar.gz::http://hg.mozilla.org/chatzilla/archive/CHATZILLA_0_9_92_RELEASE.tar.gz
+ source = http://chatzilla.rdmsoft.com/xulrunner/patch/xrmakeM.diff.txt
+ source = version.patch
+ source = chatzilla.sh
+ source = chatzilla.desktop
+ sha256sums = aa61fd08f587bae6b9410216f2995ec4785f2a114630344a7204240d6fe89ec7
+ sha256sums = f56421321bad60513a6b2855119fd8ee0cee65525b8463c265d810b16bf5c229
+ sha256sums = 43d3299ccf6f59d0123fc57d0affc8014d46650869c6edc251cd5cb54093ffa1
+ sha256sums = 0cf6529326def9bbff73b04f9abd45193c41ca3c8b44dd922739c3f969701a59
+ sha256sums = 548e758a5334ea9e920fd8b21d29c0e4acd63bdd5f3c3b6eb6e5f5a79644f9cb
+
+pkgname = chatzilla
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b92ba02f8c4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=chatzilla
+pkgver=0.9.92
+_pkgver=0_9_92
+pkgrel=1
+pkgdesc='Clean, easy to use and highly extensible Internet Relay Chat (IRC) client, built on the Mozilla platform'
+arch=('any')
+url='http://chatzilla.hacksrus.com/'
+license=('MPL' 'GPL' 'LGPL')
+depends=('firefox')
+makedepends=('python2' 'unzip')
+source=("$pkgname-$pkgver.tar.gz::http://hg.mozilla.org/chatzilla/archive/CHATZILLA_${_pkgver}_RELEASE.tar.gz"
+ "http://chatzilla.rdmsoft.com/xulrunner/patch/xrmakeM.diff.txt"
+ "version.patch"
+ "chatzilla.sh"
+ "chatzilla.desktop")
+sha256sums=('aa61fd08f587bae6b9410216f2995ec4785f2a114630344a7204240d6fe89ec7'
+ 'f56421321bad60513a6b2855119fd8ee0cee65525b8463c265d810b16bf5c229'
+ '43d3299ccf6f59d0123fc57d0affc8014d46650869c6edc251cd5cb54093ffa1'
+ '0cf6529326def9bbff73b04f9abd45193c41ca3c8b44dd922739c3f969701a59'
+ '548e758a5334ea9e920fd8b21d29c0e4acd63bdd5f3c3b6eb6e5f5a79644f9cb')
+
+prepare() {
+ cd $pkgname-CHATZILLA_${_pkgver}_RELEASE
+ patch -Np1 -i ../xrmakeM.diff.txt
+ patch -Np1 -i ../version.patch
+}
+
+build() {
+ cd $pkgname-CHATZILLA_${_pkgver}_RELEASE/xpi
+ python2 makexpi.py
+}
+
+package() {
+ install -dm755 "$pkgdir/usr/share/chatzilla"
+ unzip $pkgname-CHATZILLA_${_pkgver}_RELEASE/xpi/$pkgname-$pkgver.en-US.xulapp -d "$pkgdir/usr/share/$pkgname"
+ install -Dm755 $pkgname.sh "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 chatzilla-CHATZILLA_0_9_92_RELEASE/xpi/resources/chatzilla-window.xpm "$pkgdir/usr/share/pixmaps/$pkgname.xpm"
+}
diff --git a/chatzilla.desktop b/chatzilla.desktop
new file mode 100644
index 000000000000..d3480c46989a
--- /dev/null
+++ b/chatzilla.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=ChatZilla
+Comment=Clean, easy to use and highly extensible Internet Relay Chat (IRC) client
+Exec=chatzilla %u
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Icon=chatzilla
+Categories=Network;InstantMessaging;
+StartupNotify=true
diff --git a/chatzilla.sh b/chatzilla.sh
new file mode 100755
index 000000000000..36030f161c69
--- /dev/null
+++ b/chatzilla.sh
@@ -0,0 +1 @@
+XUL_APP_FILE="/usr/share/chatzilla/application.ini" exec firefox "$@"
diff --git a/version.patch b/version.patch
new file mode 100644
index 000000000000..0fa52c279e23
--- /dev/null
+++ b/version.patch
@@ -0,0 +1,12 @@
+diff -Naur chatzilla-CHATZILLA_0_9_92_RELEASE.orig/xpi/resources/application.ini chatzilla-CHATZILLA_0_9_92_RELEASE/xpi/resources/application.ini
+--- chatzilla-CHATZILLA_0_9_92_RELEASE.orig/xpi/resources/application.ini 2016-07-31 19:19:41.720447000 +0200
++++ chatzilla-CHATZILLA_0_9_92_RELEASE/xpi/resources/application.ini 2016-07-31 19:25:03.709837681 +0200
+@@ -6,7 +6,7 @@
+
+ [Gecko]
+ MinVersion=17.0
+-MaxVersion=25.*
++MaxVersion=*
+
+ [XRE]
+ EnableExtensionManager=Truly, yes.