summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAzat Khuzhin2023-12-02 22:44:35 +0100
committerAzat Khuzhin2023-12-02 22:52:14 +0100
commit7fcf5a24ae6ba46bd82cef523b76a63e68765355 (patch)
treed7bbc79939cba55c47853541472463f6edd3a4b3
downloadaur-7fcf5a24ae6ba46bd82cef523b76a63e68765355.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7222dcda2db8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = chdig-bin
+ pkgdesc = Dig into ClickHouse with TUI interface
+ pkgver = v0.4.0
+ pkgrel = 1
+ url = https://github.com/azat/chdig
+ arch = x86_64
+ license = MIT
+ provides = chdig
+ conflicts = chdig
+ source = https://github.com/azat/chdig/releases/download/v0.4.0/chdig-latest-x86_64.pkg.tar.zst
+ sha256sums = SKIP
+
+pkgname = chdig
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d81aed70dd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Azat Khuzhin <a3at.mail@gmail.com>
+pkgbase=chdig-bin
+pkgname=chdig
+pkgver=v0.4.0
+pkgrel=1
+pkgdesc="Dig into ClickHouse with TUI interface"
+arch=('x86_64')
+conflicts=("chdig")
+provides=("chdig")
+url="https://github.com/azat/chdig"
+license=('MIT')
+
+source=(
+ "https://github.com/azat/chdig/releases/download/$pkgver/chdig-latest-x86_64.pkg.tar.zst"
+)
+
+sha256sums=(
+ 'SKIP'
+)
+
+package() {
+ tar -C "$pkgdir" -xvf chdig-latest-x86_64.pkg.tar.zst
+ rm -f "$pkgdir/.PKGINFO"
+ rm -f "$pkgdir/.MTREE"
+}
+# vim set: ts=4 sw=4 et