summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluxferresum2015-11-30 20:52:59 +0100
committerluxferresum2015-11-30 20:52:59 +0100
commitaa96d4795107d2dc7f260152fe37ec3a18d89261 (patch)
tree3fc497a27173d2ccfd23f710f3e33c654042de87
downloadaur-aa96d4795107d2dc7f260152fe37ec3a18d89261.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
-rwxr-xr-xchdkptp-gui.sh11
-rwxr-xr-xchdkptp.sh11
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23fb79336f10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = chdkptp
+ pkgver = r690
+ pkgrel = 1
+ url = https://www.assembla.com/spaces/chdkptp
+ arch = x86_64
+ license = GPL
+ license = MIT
+ source = https://www.assembla.com/spaces/chdkptp/documents/bEQP3wxwir5ikeacwqEsg8/download/bEQP3wxwir5ikeacwqEsg8
+ source = chdkptp.sh
+ source = chdkptp-gui.sh
+ md5sums = 5832ba459c52f1cc045afdfb365dcb55
+ md5sums = d7946256ddd99be97592fd4df7d3ae86
+ md5sums = dbcda126bcdf108a8f20fe49d921cadc
+
+pkgname = chdkptp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c012191142c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Lukas Kohler <lux@ontheblueplanet.com>
+pkgname=chdkptp
+pkgver=r690
+pkgrel=1
+epoch=
+pkgdesc=""
+arch=("x86_64")
+url="https://www.assembla.com/spaces/chdkptp"
+license=('GPL' 'MIT')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+source=("https://www.assembla.com/spaces/chdkptp/documents/bEQP3wxwir5ikeacwqEsg8/download/bEQP3wxwir5ikeacwqEsg8" "chdkptp.sh" "chdkptp-gui.sh")
+noextract=()
+md5sums=("5832ba459c52f1cc045afdfb365dcb55" "d7946256ddd99be97592fd4df7d3ae86" "dbcda126bcdf108a8f20fe49d921cadc")
+validpgpkeys=()
+
+package() {
+ install -Dm755 chdkptp $pkgdir/usr/lib/chdkptp/chdkptp
+ install -Dm755 chdkptp_gui $pkgdir/usr/lib/chdkptp/chdkptp_gui
+ install -dm644 "$pkgdir/usr/lib/chdkptp/lua/extras"
+ install -m644 lua/*.lua "$pkgdir"/usr/lib/chdkptp/lua/
+ install -m644 lua/extras/*.lua "$pkgdir"/usr/lib/chdkptp/lua/extras/
+ install -Dm755 chdkptp.sh "$pkgdir"/usr/bin/chdkptp
+ install -Dm755 chdkptp-gui.sh "$pkgdir"/usr/bin/chdkptp-gui
+}
diff --git a/chdkptp-gui.sh b/chdkptp-gui.sh
new file mode 100755
index 000000000000..2a2d0c3475ee
--- /dev/null
+++ b/chdkptp-gui.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+# copy this file to chdkptp.sh and ajust for your configuration
+# to use the GUI build from a binary package that includes both CLI and GUI change to chdkptp_gui
+CHDKPTP_EXE=chdkptp_gui
+# path where chdkptp is installed
+CHDKPTP_DIR=/usr/lib/chdkptp
+# LD_LIBRARY_PATH for shared libraries
+# only need if you have compiled IUP support and have NOT installed the libraries to system directories
+#export LD_LIBRARY_PATH=/path/to/iup:/path/to/cd
+export LUA_PATH="$CHDKPTP_DIR/lua/?.lua"
+"$CHDKPTP_DIR/$CHDKPTP_EXE" "$@"
diff --git a/chdkptp.sh b/chdkptp.sh
new file mode 100755
index 000000000000..138e4db80950
--- /dev/null
+++ b/chdkptp.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+# copy this file to chdkptp.sh and ajust for your configuration
+# to use the GUI build from a binary package that includes both CLI and GUI change to chdkptp_gui
+CHDKPTP_EXE=chdkptp
+# path where chdkptp is installed
+CHDKPTP_DIR=/usr/lib/chdkptp
+# LD_LIBRARY_PATH for shared libraries
+# only need if you have compiled IUP support and have NOT installed the libraries to system directories
+#export LD_LIBRARY_PATH=/path/to/iup:/path/to/cd
+export LUA_PATH="$CHDKPTP_DIR/lua/?.lua"
+"$CHDKPTP_DIR/$CHDKPTP_EXE" "$@"