summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-04-07 18:15:12 -0600
committerJoost Bremmer2020-04-10 01:36:34 +0200
commit3e862a3d1dced17b03e040a00c091161ce1cb151 (patch)
tree961b5cf470dda2023775a1c6973205ac570994f2
parentbdbfefcdfa5b7112ff933fad16b353225348287f (diff)
downloadaur-3e862a3d1dced17b03e040a00c091161ce1cb151.tar.gz
upgpkg: cheat 3.9.0-1
upstream release updated to 3.9.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f553c8343bcd..d97cca845b24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cheat
pkgdesc = Allows you to create and view interactive cheatsheets on the command-line
- pkgver = 3.8.0
- pkgrel = 4
+ pkgver = 3.9.0
+ pkgrel = 1
url = https://github.com/cheat/cheat
arch = arm
arch = armv6h
@@ -14,16 +14,15 @@ pkgbase = cheat
makedepends = pandoc
optdepends = bash-completion: for bash completions
optdepends = fzf: Fuzzy Finder integration for bash-completion
- optdepends = fish: for fish completions
conflicts = python-cheat
conflicts = cheat-bash-git
replaces = python-cheat
backup = etc/cheat/conf.yml
- source = cheat-3.8.0.tar.gz::https://github.com/cheat/cheat/archive/3.8.0.tar.gz
+ source = cheat-3.9.0.tar.gz::https://github.com/cheat/cheat/archive/3.9.0.tar.gz
source = conf.yml
source = git+https://github.com/cheat/cheatsheets.git
source = https://raw.githubusercontent.com/cheat/cheatsheets/master/.github/LICENSE.txt
- sha256sums = daa183b9328704bbd00fc423144ce29652b1750e895dbf9c99b131d98b7f01ec
+ sha256sums = 404081005628cccbbe576567cf3aa1e8d93c618230c9119ae74ce27366cddb1e
sha256sums = efffbe20041efc3d49ffe596ab5abe60a10adf70219c2ddecdf1caf350972212
sha256sums = SKIP
sha256sums = a2010f343487d3f7618affe54f789f5487602331c0a8d03f49e9a7c547cf0499
diff --git a/PKGBUILD b/PKGBUILD
index fa223e1926b7..0ee728aac8a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,23 @@
# Co-Maintainer: Joost Bremmer <contact at madeofmagicandwires dot online>
# Contributor: Bogdan <d0xi at inbox dot ru>
pkgname=cheat
-pkgver=3.8.0
-pkgrel=4
+pkgver=3.9.0
+pkgrel=1
pkgdesc="Allows you to create and view interactive cheatsheets on the command-line"
arch=('arm' 'armv6h' 'armv7h' 'x86_64')
url="https://github.com/cheat/cheat"
license=('MIT' 'CC0 1.0 Universal')
makedepends=('go-pie' 'git' 'pandoc')
optdepends=('bash-completion: for bash completions'
- 'fzf: Fuzzy Finder integration for bash-completion'
- 'fish: for fish completions')
+ 'fzf: Fuzzy Finder integration for bash-completion')
conflicts=("python-$pkgname" "$pkgname-bash-git")
replaces=("python-$pkgname")
backup=("etc/$pkgname/conf.yml")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
'conf.yml'
"git+https://github.com/$pkgname/cheatsheets.git"
"https://raw.githubusercontent.com/$pkgname/cheatsheets/master/.github/LICENSE.txt")
-sha256sums=('daa183b9328704bbd00fc423144ce29652b1750e895dbf9c99b131d98b7f01ec'
+sha256sums=('404081005628cccbbe576567cf3aa1e8d93c618230c9119ae74ce27366cddb1e'
'efffbe20041efc3d49ffe596ab5abe60a10adf70219c2ddecdf1caf350972212'
'SKIP'
'a2010f343487d3f7618affe54f789f5487602331c0a8d03f49e9a7c547cf0499')
@@ -58,6 +57,7 @@ package() {
install -Dm755 "scripts/$pkgname.bash" \
"$pkgdir/usr/share/bash-completion/completions/$pkgname"
install -Dm755 "scripts/$pkgname.fish" -t "$pkgdir/usr/share/fish/completions"
+ install -Dm755 "scripts/$pkgname.zsh" "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/$pkgname-LICENSE"
install -Dm644 "doc/$pkgname.1" -t "$pkgdir/usr/share/man/man1"