summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-03-18 09:05:21 -0600
committerMark Wagie2022-03-18 09:05:21 -0600
commit54a00a36b26372dbed088453780f8a1de465fb2e (patch)
treee4b3f45c8a0966f764219756805bdf3f4dd85ed9
parent94f3ec6e69be8294f0c7bedaf8aaf559da46a863 (diff)
downloadaur-54a00a36b26372dbed088453780f8a1de465fb2e.tar.gz
clean module cache for makepkg -C
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 831fd1d3071e..e5b7cde0bfed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cheat
pkgdesc = Allows you to create and view interactive cheatsheets on the command-line
pkgver = 4.2.3
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/cheat/cheat
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 16c2fb61b9a2..fc960e4a8063 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Bogdan <d0xi at inbox dot ru>
pkgname=cheat
pkgver=4.2.3
-pkgrel=3
+pkgrel=4
pkgdesc="Allows you to create and view interactive cheatsheets on the command-line"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="https://github.com/cheat/cheat"
@@ -28,11 +28,11 @@ prepare() {
cd "$pkgname-$pkgver"
export GOPATH="$srcdir/gopath"
- # create directory for build output
- mkdir -p build
-
# download dependencies
go mod download -x
+
+ # create directory for build output
+ mkdir -p build
}
build() {
@@ -43,10 +43,13 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -o build -v "./cmd/$pkgname"
+ go build -v -o build "./cmd/$pkgname"
# Generate man page
pandoc -s -t man "doc/$pkgname.1.md" -o "doc/$pkgname.1"
+
+ # Clean module cache for makepkg -C
+ go clean -modcache
}
package() {