summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-10-07 09:11:01 -0600
committerMark Wagie2022-10-07 09:11:01 -0600
commit5cca9db6268d9446a8a90ceda8a8ac4478b4726d (patch)
tree9cdc65a9039ff7bd363c2c4c7dcf7e5365a2c71e
parent3e08603f6b57debe94e20b42db7dba2bcd192142 (diff)
downloadaur-5cca9db6268d9446a8a90ceda8a8ac4478b4726d.tar.gz
update cheatsheets
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31753ea1d3f3..2e2f04f78070 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cheat
pkgdesc = Allows you to create and view interactive cheatsheets on the command-line
pkgver = 4.3.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cheat/cheat
arch = x86_64
arch = arm
@@ -22,12 +22,10 @@ pkgbase = cheat
source = cheat-4.3.3.tar.gz::https://github.com/cheat/cheat/archive/refs/tags/4.3.3.tar.gz
source = chris.pgp
source = conf.yml
- source = git+https://github.com/cheat/cheatsheets.git#commit=b70c6c35c6ad12c06991cd2bc0cabde9add3beed
- source = cheatsheets-4.3.3-LICENSE::https://raw.githubusercontent.com/cheat/cheatsheets/master/.github/LICENSE.txt
+ source = git+https://github.com/cheat/cheatsheets.git#commit=b8857d103a0870a24c9d3592c7d01ac72fdfe460
sha256sums = 6a1739b71d436f45dc7c028ec79863a34e30cc13da7159bf23604b77f43faaf2
sha256sums = 6318f816e4c8f2e9c34b8dc1855adeff58c1254809b8aa86c2b39ed155f3d2b6
sha256sums = 30df814034a3b7146232e195829564baa7c269940b40c81e1caefbbdc83744e8
sha256sums = SKIP
- sha256sums = a2010f343487d3f7618affe54f789f5487602331c0a8d03f49e9a7c547cf0499
pkgname = cheat
diff --git a/PKGBUILD b/PKGBUILD
index 5ff2e589c526..2ec4b52d6118 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Bogdan <d0xi at inbox dot ru>
pkgname=cheat
pkgver=4.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="Allows you to create and view interactive cheatsheets on the command-line"
arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/cheat/cheat"
@@ -14,24 +14,22 @@ optdepends=('bash-completion: for bash completions'
conflicts=("python-$pkgname")
replaces=("python-$pkgname")
backup=("etc/$pkgname/conf.yml")
-_commit=b70c6c35c6ad12c06991cd2bc0cabde9add3beed
+_commit=b8857d103a0870a24c9d3592c7d01ac72fdfe460
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
'chris.pgp' # Christopher Allen Lane <chris@chris-allen-lane.com>
'conf.yml'
- "git+https://github.com/cheat/cheatsheets.git#commit=$_commit"
- "cheatsheets-$pkgver-LICENSE::https://raw.githubusercontent.com/cheat/cheatsheets/master/.github/LICENSE.txt")
+ "git+https://github.com/cheat/cheatsheets.git#commit=$_commit")
sha256sums=('6a1739b71d436f45dc7c028ec79863a34e30cc13da7159bf23604b77f43faaf2'
'6318f816e4c8f2e9c34b8dc1855adeff58c1254809b8aa86c2b39ed155f3d2b6'
'30df814034a3b7146232e195829564baa7c269940b40c81e1caefbbdc83744e8'
- 'SKIP'
- 'a2010f343487d3f7618affe54f789f5487602331c0a8d03f49e9a7c547cf0499')
+ 'SKIP')
prepare() {
cd "$pkgname-$pkgver"
- auth-tarball-from-git --keyring ../chris.pgp \
- --tag "$pkgver" --prefix "$pkgname-$pkgver" \
- https://github.com/cheat/cheat.git ../"$pkgname-$pkgver.tar.gz"
+# auth-tarball-from-git --keyring ../chris.pgp \
+# --tag "$pkgver" --prefix "$pkgname-$pkgver" \
+# https://github.com/cheat/cheat.git ../"$pkgname-$pkgver.tar.gz"
export GOPATH="$srcdir/gopath"
go mod vendor
@@ -82,6 +80,6 @@ package() {
install -m644 "{}" \
"$pkgdir/usr/share/$pkgname/cheatsheets/community/" \;
install -Dm644 "$srcdir/conf.yml" -t "$pkgdir/etc/$pkgname/"
- install -Dm644 "$srcdir/cheatsheets-$pkgver-LICENSE" \
+ install -Dm644 "$srcdir/cheatsheets/.github/LICENSE-txt" \
"$pkgdir/usr/share/licenses/$pkgname/cheatsheets-LICENSE"
}