summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-04-28 11:34:08 -0600
committerMark Wagie2021-04-28 11:34:08 -0600
commita553dfcf67f014a39464f9fe18c4cbe400271df4 (patch)
tree42cccddb32084b9d1ae7b42e5e90f2fbb29f7138
parentb451cf4203adad72da0e1ee8121a87138ac172f8 (diff)
downloadaur-a553dfcf67f014a39464f9fe18c4cbe400271df4.tar.gz
4.2.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 614716dad1ba..68dfb8456399 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cheat
pkgdesc = Allows you to create and view interactive cheatsheets on the command-line
- pkgver = 4.2.0
- pkgrel = 4
+ pkgver = 4.2.1
+ pkgrel = 1
url = https://github.com/cheat/cheat
arch = i686
arch = x86_64
@@ -19,11 +19,11 @@ pkgbase = cheat
conflicts = cheat-bash-git
replaces = python-cheat
backup = etc/cheat/conf.yml
- source = cheat-4.2.0.tar.gz::https://github.com/cheat/cheat/archive/4.2.0.tar.gz
+ source = cheat-4.2.1.tar.gz::https://github.com/cheat/cheat/archive/4.2.1.tar.gz
source = conf.yml
source = git+https://github.com/cheat/cheatsheets.git
- source = https://github.com/cheat/cheat/raw/4.2.0/LICENSE.txt
- sha256sums = 23c3c30fe1ad63916718eef534dcef22c0ae607695f74860180304c5cde3ea49
+ source = https://github.com/cheat/cheat/raw/4.2.1/LICENSE.txt
+ sha256sums = 2a63b18bf8d55b865606f4be91af3650aacff70b8c9b8729661d60323367d455
sha256sums = a0aa691a318219d048107b835fe0e8cddfa734618fc5ccbb800b5bb463e00ea5
sha256sums = SKIP
sha256sums = 5eaa85b8023f915629de53c3604015ab5b23bed404afa9e551ab44e0bc46dde3
diff --git a/PKGBUILD b/PKGBUILD
index 5ca1eee12d5f..23109587ad65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Co-Maintainer: Joost Bremmer <contact at madeofmagicandwires dot online>
# Contributor: Bogdan <d0xi at inbox dot ru>
pkgname=cheat
-pkgver=4.2.0
-pkgrel=4
+pkgver=4.2.1
+pkgrel=1
pkgdesc="Allows you to create and view interactive cheatsheets on the command-line"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="https://github.com/cheat/cheat"
@@ -19,12 +19,15 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
'conf.yml'
'git+https://github.com/cheat/cheatsheets.git'
"https://github.com/cheat/cheat/raw/$pkgver/LICENSE.txt")
-sha256sums=('23c3c30fe1ad63916718eef534dcef22c0ae607695f74860180304c5cde3ea49'
+sha256sums=('2a63b18bf8d55b865606f4be91af3650aacff70b8c9b8729661d60323367d455'
'a0aa691a318219d048107b835fe0e8cddfa734618fc5ccbb800b5bb463e00ea5'
'SKIP'
'5eaa85b8023f915629de53c3604015ab5b23bed404afa9e551ab44e0bc46dde3')
prepare() {
+ # Prevent creation of a `go` directory in one's home.
+ # Sometimes this directory cannot be removed with even `rm -rf` unless
+ # one becomes root or changes the write permissions.
export GOPATH="$srcdir/gopath"
go clean -modcache
}