summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-06-10 00:37:47 -0400
committerKevin MacMartin2015-06-10 00:37:47 -0400
commitda183fff60682581ba1574c74ae050fdcb8609a0 (patch)
treef315bb51f26faca9fef4f8c175714db7fdb023e9
downloadaur-da183fff60682581ba1574c74ae050fdcb8609a0.tar.gz
Initial import into AUR 4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..565b02c790ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cheat-bash-git
+ pkgdesc = A Bash reimplementation of a command line tool to create and view interactive cheatsheets
+ pkgver = 20140917.r29.19f26b8
+ pkgrel = 1
+ url = https://github.com/jahendrie/cheat
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = bash
+ source = git://github.com/jahendrie/cheat.git#branch=master
+ sha512sums = SKIP
+
+pkgname = cheat-bash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0bf732639991
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+
+_pkgname=cheat
+pkgname=${_pkgname}-bash-git
+pkgver=20140917.r29.19f26b8
+pkgrel=1
+pkgdesc="A Bash reimplementation of a command line tool to create and view interactive cheatsheets"
+url="https://github.com/jahendrie/${_pkgname}"
+license=('GPL3')
+arch=('any')
+depends=('bash')
+makedepends=('git')
+source=("git://github.com/jahendrie/${_pkgname}.git#branch=master")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_pkgname
+ install -Dm755 src/${_pkgname}.sh "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 doc/${_pkgname}.1.gz "${pkgdir}/usr/share/man/man1/${_pkgname}.1.gz"
+ install -d "${pkgdir}//usr/share/${_pkgname}"
+ cp -R data/* "${pkgdir}/usr/share/${_pkgname}/"
+}