summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuan Guo2019-01-30 18:00:06 +0800
committerQuan Guo2019-01-30 18:00:06 +0800
commite1b5bcfe774b03ed8068e3d35fd2991156895983 (patch)
tree01c2d161fe87819f6cf7f5a86c61c69276d66cff
parent6f25f1c349c3fc3d31e22c6cf68e644f5697a3fb (diff)
downloadaur-e1b5bcfe774b03ed8068e3d35fd2991156895983.tar.gz
Add zsh and fish competion
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e83308e9dec6..79403aab7cd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,16 @@
# Maintainer: Quan Guo < guotsuan@gmail.com>
pkgname=cheat-git
-pkgver=2.2.3
+_gitname=cheat
+pkgver=2.4.2
pkgrel=1
pkgdesc="Cheat allows you to create and view interactive cheatsheets on the command-line"
arch=('any')
license=('GPL3')
url="https://github.com/chrisallenlane/cheat"
depends=('python2' 'python2-docopt')
-optdepends=('python2-pygments' 'bash-completion')
-makedepends=('git')
+optdepends=('python2-pygments' 'bash-completion' 'zsh-completions' 'fish')
+makedepends=('git' 'python-setuptools')
conflicts=('cheat-bash-git' 'python-cheat')
source=("$pkgname::git+https://github.com/chrisallenlane/cheat.git")
md5sums=('SKIP')
@@ -24,7 +25,11 @@ pkgver() {
package(){
cd "$pkgname"
- python2 setup.py install --root=$pkgdir
- install -dm755 ${pkgdir}/usr/share/bash-completion/completions/
- install -m 644 ${srcdir}/$pkgname/cheat/autocompletion/cheat.bash $pkgdir/usr/share/bash-completion/completions/
+ python2 setup.py install --root=$pkgdir --optimize=1
+ install -dm755 ${pkgdir}/usr/share/{bash-completion/completions/,zsh/site-functions,fish/completions}
+ install -m 644 "${srcdir}/$pkgname/cheat/autocompletion/cheat.bash $pkgdir/usr/share/bash-completion/completions/
+ install -m 644 "$srcdir/$_gitname/$_gitname/autocompletion/cheat.zsh" "$pkgdir/usr/share/zsh/site-functions/$_gitname"
+ install -m 644 "$srcdir/$_gitname/$_gitname/autocompletion/cheat.fish" "$pkgdir/usr/share/fish/completions/$_gitname"
+}
+
}