summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Scott2023-05-28 20:12:03 -0400
committerAndrew Scott2023-05-28 20:12:03 -0400
commit33e35e6a4d54dd1f25db8b04685bcbe51aa0c0c8 (patch)
treed6b2887e1f5764b7c4265c825e49e187f4513c2a
downloadaur-33e35e6a4d54dd1f25db8b04685bcbe51aa0c0c8.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..329eb1b98c8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = check-link-consistency-git
+ pkgdesc = Checks linked files like revdep-rebuild with additional features for Arch Linux
+ pkgver = r29.6a0e048
+ pkgrel = 1
+ url = https://github.com/dimgel/check-link-consistency
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = libarchive
+ depends = libelf
+ provides = check-link-consistency
+ conflicts = check-link-consistency
+ source = check-link-consistency::git+https://github.com/dimgel/check-link-consistency.git
+ b2sums = SKIP
+
+pkgname = check-link-consistency-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e220a257c64e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Andrew Scott <aur at andyscott dot me>
+_pkgname=check-link-consistency
+pkgname="${_pkgname}-git"
+pkgver=r29.6a0e048
+pkgrel=1
+pkgdesc="Checks linked files like revdep-rebuild with additional features for Arch Linux"
+arch=('x86_64')
+url='https://github.com/dimgel/check-link-consistency'
+license=('GPL3')
+depends=('libarchive' 'libelf')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}"::git+https://github.com/dimgel/"${_pkgname}".git)
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long --abbrev=7 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ )
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}